CAC-1070 Intel Graphics 4600, 4K 60 HZ issue

Updated on 18-04-2017 in Adapters and Cables
14 on 27-03-2017

Hi All,

My first post on the forum! Have been reading and trying many of the suggestions re the 4k 60hz issue with Intel 4600. Thanks to all who provided so much feedback!!
Before I described my setup, I confirm that I had 4K 3840×2160 60HZ working on a Skylake I7 6500U Intel HD 520 so I know the CAC-1070, HDMI cable and TV settings are all good.
Unfortunately the I7 6500U was a bit too weak and I had to switch to an I7-4790 3.6 with Intel HD 4600.
So setup as follows
CAC-1070 DP to HDMI 2.0, firmware 0X07 0X26
18gps HDMI 2.0 cable
LG 49UH668V with HDR enabled on HDMI connected to PC
Dell OptiPlex 9020, 4th Gen I7-4790 with Intel Graphics 4600
Graphics Drivers: 20.19.15.4501 from Intel, not the ones from Dell, I followed instructions from on how to manually install those.
So I tried the custom resolution solution and although I can set 3840×2160 60hz custom res, if I try to select it in General Settings, the screen goes black and then returns to 30hz.
I also tried connecting a second monitor as advised in another post with the same results.

Sorry for the long post, just want to be sure I give as much info as possible.
Hoping there’s a solution for the issue.

Thanks for the help in advance!!!!

  • Liked by
Reply
5 on 28-03-2017

Another point I forgot to mention. I cannot see the Dell bios startup screen. Picture only comes when Win10 starts.
I am not sure if this is related as I read there’s a handshake with the adapter when the PC starts.
Where can I get the latest firmware for the 1070?
Thanks

on 29-03-2017

Hi Palinkat,

For 4th generation Intel Integrated Grpahcis i have very good experience with this driver pack: 15.40.25.4463. 
You can find it here: https://downloadcenter.intel.com/download/26079/Intel-Graphics-Driver-for-Windows-10-15-40-4th-Gen-?product=81496 
Manually download and install (don’t let that auto-updater from Intel or Windows do that).
I know there is / are newer versions, but those did not run closesly as well as this one.

And yes  is a bit of a pioneer with the Intel Integrated Grpahics 🙂
Anyway, in case you would need a little help setting up the cusotm resolution again after Driver isntallation…

  • Custom Resolution Intel Graphics Software

Making that Custom resolution in the Intel Graphics Driver should be something like this …

Open Intel Graphics Control Panel, Chose “Custom Resolutions” (left bottom option) It will asks you if you wish to continue; YES
Standard the “Basic” setting is shown, click on “Advanced” , make sure you make this custom resolution for the correct screen (left bottom)
Fill in; Width 3840 ; Height 2160 ; Refresh Rate 60 ; Set Timing Standard to CVT-RB for use with TV (and for use with Monitor you can leave that on “Auto”). If possible please set Color Depth BPC to 8 Bit. and click on “ADD” on the right bottom of the window. Now this resolution I added to the system and can be chosen. 
Go back to “General Settings”(left top) , it will show the basic options and here you can now choose the 3840×2160 resolution at 60Hz. 
(You might need to so a reboot first)

I will ask [email protected] to send you latest firmware. I do not think the issue you are having is realted to firmware though.

on 29-03-2017
Thanks a lot MST1407!
I tried those drivers but still the same result unfortunately. when I choose 3840×2160 60hz, the screen goes black and after 10 secs it defaults back to 30hz.
Real pain, Support sent me the latest firmware, flashed, restarted, tried again, same results, as you suggested.
Am pretty sure it’s related somehow to the fact I have no picture during BIOS post.
Not sure what else to do, maybe you have other ideas?
Thanks for the help!
on 29-03-2017

– Make sure to have the timing standard set to CVT-RB when making the custom resolution
– Disable HDR
– Enable UHD Color on the TV

on 29-03-2017

Thanks.
Timing standard set to CVT-RB, none of the other options allow custom res anyway
Disabled HDR on TV
I don’t see any option for UHD color on the TV so not sure.

Still defaults back to 30hz after 10 secs.

Cheers

on 30-03-2017

Page 15 of the manual …

Show more replies
  • Liked by
Reply
Cancel
7 on 30-03-2017

Thanks a lot,
I am now confused between HDR and UHD. I knew about the UHD option on the TV (it is enabled) but I thought it’s to enable HDR per input.
I can’t see any other option to disable HDR on that model. There’s no Picture expert settings like ion the 2015 model.
Thanks

on 30-03-2017

ah ok.
Well HDR signal is send from the source, not from the TV so that should not be the problem, as long as you dont send HDR enabled content over the adapter.
The only we have not looked at is the Pixel Clock. Sometimes when EDID info is not received/read in a correct manner, the sytem might choose a pixel clock not supported by the screen. Especially with high end screens that can happen because they sometimes support a pixel clock of up to 594 Mhz, where the system might chose a more “standard” frequency of 533 Mhz or something like that.
You can use a program like Custom Resolution Utility (CRU), to check on Pixel Clock Frequency of your screen, You can find that here: http://www.monitortests.com/forum/thread-custom-resolution-utility-cru

In this program you can also make a custom resoution that will overrule the current grpahics driver settign and also chose a pixel clock.

on 02-04-2017

Thanks a lot, downloaded and followed instructions. However I am still not able to get the 60hz to stick. Do I still need to use the custom resolution from Intel Graphics properties.
What settings are required exactly in the CRU? Sorry tried to upload a screenshot but can’t do it for some reasons (Browse button is greyed out).
Cheers again.

on 04-04-2017

That CRU program will overwrite the Intel Graphcis Driver.
Normally just filling in 3840 and 2160 and 60 hz (or 59 Hz) and setting the Pixel Clock from 533 or 539 (whatever it standard value) to 594 Mhz, should be enough.

on 13-04-2017

I have tried everything with the CRU program but to no avail.
I cannot get the 60 hz to stick.

on 14-04-2017

Very sorry to hear this … because i am out of suggestions 🙁
We knwo all the other parts work so i am putting this on the  I7-4790 or its integrated graphics … did you ask feedback from Intel already ?

on 16-04-2017

That’s no problem, it’s a bit of fun :).
Actually there’s one more thing I want to try before I purchase a discreet GPU.
I am having trouble when I install the latest Intel drivers. Windows replaces them straight away with the DELL signed drivers.
How can I stop Windows from overwriting them?

Cheers

on 18-04-2017

i think you should be able to “disable” auto updates or put that on “Manual”

Show more replies
  • Liked by
Reply
Cancel