CAC-1070 not working on RCA 65 inch 4k TV (PRK65A65RQ) with AMD RADEON R7 260X 2GB D5 card

Updated on 11-04-2016 in R7 260 Series
5 on 06-04-2016

Tried CAC-1070 on a “DD RADEON R7 260X 2GB D5 DP HDMI 2XDVI” card hoping to make 4k 60hz work on my RCA 4k TV. However, the max resolution allowed in Windows 10 is 1080p at 60hz although I can get 4k at 30hz without the adapter in both HDMI 2.0 and HDMI 1.x ports.

Updated the firmware and no luck at all.

The 4k TV is RCA 65 inch (Model: PRK65A65RQ)

Please help.

Thanks.

  • Liked by
Reply
0 on 06-04-2016

Hi j48888, thank you for joining our forum! To help shoot the troubles, can you please confim:

  • which (AMD) driver are you using?
  • what type of HDMI cable are you using?
  • have you tried to create a custom resolution? 

Thanks!

  • Liked by
Reply
Cancel
0 on 07-04-2016

Hi RoyalKing,

Thanks for your reply. The AMD driver version is 16.150.2211.0 dated on 3/21/2016, which is the latest driver. I tried using 3 generic 6 foot long hdmi cables. The results were same. Since the max resolution is 1080p with CAC-1070, I wonder if a good cable would make my tv to display 4k/60hz.

I also tried to use AMD Radeon Setting tool to change virtual settings. The max settings available were 2048×1536 or 2560×1440 at 60Hz. However virtual settings don’t produce good images.

The issue could be related to the tv or graphic card. I doubt that an expensive hdmi cable would make any difference as my generic hdmi cables with CAC-1070 can’t even display 4k/30hz resolution not mention 4k at 60hz. (Without CAC-1070, the cables can reliably display 4k/30hz on the tv)

Thanks.

  • Liked by
Reply
Cancel
1 on 07-04-2016

Hi J48888,

The R7 260X can most certainly do it, this is tested here.

On many TV’s you need to turn on “UHD Color” or “Advanced (Color) Setting” manually in the settings of your TV for the HDMI port to which your pc is connected.

Also it could help when connecting 2 screens, to set the screen connected thru the Adapter as second/secondary screen

I strongly advise you to make a custom resolution, set resolution to 3840×2160 at 60Hz and set Timing standard to CVT-RB (reduced blanking);

Open the Crimson Driver software

Click on “screen” ; Then on “additional settings” (right top); Then click “Custom Resolutions” and click on “NEW”. Put in 3480 and 2160 and 60Hz and set Timing Standard to CVT-Reduced Blanking.

O do advise you to try an HDMI cable of which you are certain (certified) it will support 18Gbps or 3840×2160 at 60Hz, perhaps you can borrow one from a friend. Many issue come from cables that are in fact not capable of supporting such high resolutions. Something like this one:
CAC-1310 

I will send you an email with the latest firmware for the Adapter just in case…

on 07-04-2016

oh i just saw the latest firmware was already send to you on the 4th

Show more replies
  • Liked by
Reply
Cancel
0 on 11-04-2016

Hello MST1407,

Using customized resolution, I was only able to get 3840×2160 at 30hz. When I tried to use 60hz, I got an system error message by Windows 10: “The system has detected a problem with the connection between your computer and the DisplayPort display that will prevent you from using the highest resolution”

I am trying to fine a quality hdmil cable that has the bandwidth for 4k/60hz data. I will post my result here then.

Thanks for help.

  • Liked by
Reply
Cancel