display driver has stopped working and has succesfully recovered

Updated on 02-06-2015 in R9 290 Series
32 on 14-04-2015

I recently got a Radeon R9 290 Royalking and after few minutes running a gaming application,I get the message and the GPU Usage rockets to 100% and never goes down even with all application closed. I’ve tried using both the AMD Catalyst Omega and the new beta driver, used DDU to reinstall the drivers and changed hard drive. reinstalled windows to 8.1 and updated all bios and drivers for all other parts of the computer hardware. I still have the problem persists. i tried testing on different computer system with window 7 and still able to reproduce this problem.

  • Liked by
Reply
7 on 14-04-2015

Hi,
Open your task bar and see what app is taking the most resources available.
We think it could be a browser that is causing the problem such firefox, chrome etc.

on 14-04-2015

The problem persist with nothing but the gaming application, or the problem can even occure without any thing on at all

on 15-04-2015

Have tried this?

on 15-04-2015

I’ve already done the the trouble shooting as I talked to AMD rep prior to contacting you guys

on 15-04-2015

I do not know your hardware specifications but i suggest to update your OS, make sure your mainboard BIOS is up to date and check if your power supply can handle the graphics card power requirements.
If you are playing a specific game, did you apply all the game patches?

on 15-04-2015

My mother board is up to date, and the hardware specification is on the post with the image. The power supply I’m currently using is Corsair Professional HX650W. Pretty much all game I’ve run has this problem. Dragon Age Inquitison, Dota 2, Vindictus, World of Warcraft, Heroes of the Storm, Hearthstone, Diablo 3 and so on. They are all up to date.

on 15-04-2015

Just in case, my Specifications are

Intel i5-2500 Sandy Bridge
4GB DDR3 x2 total of 8GB Ram
Asus P8Z68X LV
Samsung SSD 850 Evo 250GB
Seagate barracuda 1TB 

on 15-04-2015

Can you try removing completely the drivers?
Try this after removing the drivers, DDU
Please follow instructions

Show more replies
  • Liked by
Reply
Cancel
5 on 15-04-2015

As I’ve stated on the main post, I have used DDU to remove the driver and reinstall them, I’ve also completely formatted my hard drives and tried. The problem still persists

on 15-04-2015

Sorry to miss that one.
Have checked if the fans are spinning correctly? Is it possible that you can test the card in a different system to verify if you have the same problem?

on 15-04-2015

I have tested on a different system already, So far I have tried on 2 different system and the problem still persists.

on 16-04-2015

Hi,
Please send the card for service since you have tested with the same results on a different system.
Regards

on 16-04-2015

I’ve visited my place of purchase, and the technician there used furmark, and does not reproduce this problem. I have been refused for an RMA, so how do I send it to you guys for service.

on 16-04-2015

Please send an email to [email protected] and answer the questions they are going to ask for service.
Regards

Show more replies
  • Liked by
Reply
Cancel
7 on 15-05-2015

I’ve just received my card from RMA Services and once again the problem has reproduced

on 16-05-2015

Also now the screen tears time to time

on 16-05-2015
on 16-05-2015

after following window’s suggestion to increase the TDR value, I get the message Application has been blocked from accessing the GPU

on 19-05-2015

You mentioned that you have two system to test, can you check if on the other system you have the same problem?

on 20-05-2015

After changing the TDR value both system no longer has screen tear, but the issue now is that the Applications like World of Warcraft, Heroes of the Storm, Dragon Age Inquisition, are being blocked from the GPU.

on 20-05-2015

is the R9 290 Royalking compatable with really old mother boards? because the systems I’m testing on are using pretty much at least 3 year old motherboards

on 20-05-2015

The R9 290 cards are compatible with your 3 year old mainboards.
I have checked your screenshot above and your mainboard BIOS is from 07/01/2013 which I think is Version 4003 above (BETA)
Can you update to Version 4105?
Here is the link 

Show more replies
  • Liked by
Reply
Cancel
8 on 20-05-2015

The bios has been updated to 4105 since the day I installed the graphics card

on 20-05-2015

Hi,
Did you get from our RMA department the same card or a different card?
Please check the serials. With this information I will check with our support team here to check what has happened.
Thanks.

on 20-05-2015

The RMA Team gave me a new box without any serial numbers and product numbers. I do believe I got the same card however.

on 21-05-2015

Can you send a mail to the RMA department and ask them the same question I have asked? Tell them it is Paul from Insights who is asking. I want to check what has happened.
Thanks and sorry for the trouble.

on 22-05-2015

The RMA department has confirmed it is the same card

on 22-05-2015

Thank you for getting back.
Please ask them to provide you a different card. If the testing went ok here we are not sure what is causing the problem in your system.
As for a swap and see if you have the same problem again.
Thank you for your patience.

on 01-06-2015

The RMA team is saying they are confident the card is not at the fault and swapping the card will fix the problem. having said that they have not taken any actions to give me a swap on the card. I haven’t heard from them over a week, so is there any other things that I might try to solve this problem

on 01-06-2015
The RMA team is saying they are confident the card is not at the fault and swapping the card will fix the problem. having said that they have not taken any actions to give me a swap on the card. I haven’t heard from them over a week, so is there any other things that I might try to solve this problemFrom OnesQuared

 
will not fix the problem*

on 01-06-2015

I will try to contact them asap.
Keep you posted

Show more replies
  • Liked by
Reply
Cancel
0 on 02-06-2015

I have received news from the support team that they have created a ticket to swap the card for you. They should be in touch asap

  • Liked by
Reply
Cancel