HD 7970 GHz Edition royal Ace graphical errors

Updated on 09-05-2016 in HD 7000 Series
7 on 18-11-2015

Hi, i’m using a HD 7970 GHz Edition royal Ace.
Sometimes i get some strange graphical errors, like in the attached Pictures so i have to restart my computer. They are not reproducible and occure mostly after standby, sometimes after starting the browser or directly after starting a game. It happens not very often, mostly i can play for hours, meaning the card is fully loaded. So i don’t think it’s a heat problem. Also stress tests and benchmarks are working fine. Even CPU and memory tests like prime or MemTest are working witout any Issue. In another PC the card has the same errors.
I have no idea what’s the problem, may you know whats the problem. Please help!

Thank you and sorry for my bad english….


  • Liked by
Reply
0 on 18-11-2015

And the card is running at stock clocks and voltages…

  • Liked by
Reply
Cancel
2 on 18-11-2015

Hi Sebastian,

If you can run games on your Graphics Card and benchmark test will run fine, the chance that there is anything wrong with your Graphics Card is not very big.
Sometime these type of errors happen due to (static) electrical issues.
Please make sure to use a power outlet with ground for your PC and if possible a power outlet with Ground for the Screen. 

Hope it helps

on 18-11-2015

Hi, MST1407, 
thank you for your fast answer!
I’dont know i understand you right.  You say power outlet with ground, meaning the 
power circuit in my apartment?
This could be a problem, cause it’s an very old house so i assume there is just no
real ground.

on 18-11-2015

But its good to hear you don’t think the card is damaged! 🙂

Show more replies
  • Liked by
Reply
Cancel
2 on 30-03-2016

Hi, it’s me again.
So after a lot of testing with different computers, power outlets, monitors, cables and also other apartments ;), i know it’s definitely a problem of the card itself. I had the same errors on every scenario…
There is also no damaged capacitor from what i can see on the card, meaning nothing is bloated or something. 
Do you have any further ideas what the problem causes? 
Last option i want to try is the latest bios.
So could you please send me the latest bioses (bios 1 and 2) or tell me where i can get it?

on 31-03-2016

Hi Sebastian,

Please send a picture of the backside of your card to [email protected]
There should be stickers there with Serial NR. / Item Code / Production Nr. Need thsoe to determine which bios is needed.
Thanks

on 09-05-2016

Hi,

I actually have that same issue with a Radeon PokerSeries HD 7850
royalKing. I have tried all the same things, to no avail.

Does updating the BIOS potentially solve this issue ?

Show more replies
  • Liked by
Reply
Cancel