screens turn black

Updated on 19-10-2015 in R9 290 Series
8 on 11-10-2015

Hello

I’m having a lot of problems with my graphical card. After reinstalling the drivers several times and even doing a clean install of windows 10 I still have one problem(had several different errors). Both my screens randomly turn black. The only choice I then have is to reboot my PC with the power button. When this happens no crash dump files are made but I do find one error in the eventviewer that keeps returning:

ATI EEU PnP start/stop failed
event ID 16396

PS: I do not have catalyst center installed since this gave me a few other errors wich gave me BSOD’s, just the raw driver from amd.

card:
club 3d r290 royal ace
screens:
iiyama ProLite E2483HS-B1 LED display * 2 
other hardware:
ASUS Z97-A
Corsair HX750i
Crucial Ballistix Tactical 8GB (4GB x 2) DDR3 1866MHz PC3-14900
Intel Core i7-4790K

OS: windows 10 (but had the same problem in windows 8.1)

greetings

  • Liked by
Reply
6 on 15-10-2015

Hi,
Did you check if you can default your BIOS settings in your mainboard?
Did you apply the latest updates on your mainboard BIOS?
Can you update the system by just placing one display instead of 2?
Can you check if the memory is giving you errors?
Regards

on 17-10-2015

hello,

Thank for your response.

It doesn’t matter whether the BIOS is in default settings or in adjusted settings, I’m getting the black screens either way.
Mainboard BIOS was updated untill the 12th of October 2015, going to update my BIOS with the latest patch now and i’m going to do it with just one screen attached. Don’t really know why I should do this since the GPU should be able to handle 2 screens with ease. Besides I really need 2 :D.
I have checked my memory several times and let the tests run for hours and hours , the results were the same no errors in the memory.

greetings

on 17-10-2015

Yes, let me know the results.

on 17-10-2015

Sadly just had it again. I was watching netflix and doing nothing else. Should i RMA the card or do you think it’s not the card?
I noticed if I wait a while(20ish seconds after screen turns black) the sound starts hanging aswell. I’ve used different power cables to see if it was a power problem. I tried to use msi afterburner so the card gets constant power but it still occurs.

on 17-10-2015

I just noticed that the error in my first post might not be the culprit since the error comes after the restart so not before the crash.

on 19-10-2015

Hi,
Do you have a second system to verify if it is the card that is providing the issues? If not please proceed to RMA the card.

on 19-10-2015

Hello,

I did a clean install of W10 with just one screen attached then I installed and upgraded everything I needed (BIOS fw upgrade and so on).
after everything was ready i attached my second screen.

Haven’t had any black screens since (1 day of use).
I’ll reply in about one week if I still have the problem or not. If I do ill test the system with another GPU since I don’t have a second system and I’ll keep you up to date.

Thanks for help so far.

Show more replies
  • Liked by
Reply
Cancel
0 on 17-10-2015
  • Liked by
Reply
Cancel