CAC-1170 not working with Sceptre U435CVU and mid 2014 mac book pro 15

Updated on 25-04-2016 in Adapters and Cables
6 on 08-04-2016

unable to get more than 3840×2160 @ 30Hz going on a Macbook Pro 15 that has the nvidia 750 graphics option through the DP 1.2 to HDMI 2.0 active adaptor (CAC–1170). Tried with a bunch of different HDMI 2.0 (marketed) cables , it pretty much the same output i get from the hdmi port on the mac .

Any help on this regard would be appreciated .

 
  • Liked by
Reply
0 on 08-04-2016

Hi Vishal,

Here’s my standard checklist:

* Color Depth (often default set to 16 bits or even 32 bits) need to be set to 8 bits (when running 4:4:4).

What are the 4K formats supported by the adapter ?

* Make sure the HDMI cable you are using can do HDMI2.0 or 18Gbps.

Sound a bit “easy” but many cable do actually not support the full bandwidth, certainly  not cables longer than 3 meters …

* On many TV’s you need to turn on “UHD Color” or “Advanced (Color) Setting” manually in the settings of your TV for the HDMI port to which your pc is connected.

* Also it could help when connecting 2 screens, to set the screen connected thru the Adapter as second/secondary screen

* I strongly advise you to make a custom resolution, set resolution to 3840×2160 at 60Hz and set Timing standard to CVT-RB (reduced blanking)

  • Liked by
Reply
Cancel
0 on 10-04-2016

Thanks for the feedback . Unfortunately no luck in getting it to work.

HDMI cable is from amazon basics and rated at 18Gbps  HDMI 2.0 , tried with other cables i had lying around (xbox One ) and there is no difference. 

using  SwitchResX  does not meet minimum security guidelines to install on  a macbook pro ( as the App has no App Store account ) and is merely a binary distribution over the internet.  

Using this adaptor with a HDMI 2.0 screen for the Mac OS X El Capitan is definitely a problem ( even if the MacBookPro is capable of [email protected] through the DP ) .

  • Liked by
Reply
Cancel
0 on 13-04-2016

Hi Vishal,

Sorry to hear that you were not able to get it working. I know the mac book pro supports it, i know the adapter supports it, you know the cable supports it … that leaves cable and tv
I would say it must be a setting somewhere …

  • Liked by
Reply
Cancel
1 on 15-04-2016

it is a setting problem . Got it to work with 2013 intel HD 4400 (dell xps 13 – i7 4500U)  with 3840×[email protected] Hz  ( the 4400 max is 3200×[email protected] if i remember correctly). 
Thank you for the prompt response and helpful feedback .

on 15-04-2016

good to hear, thanks for the feedback 🙂

Show more replies
  • Liked by
Reply
Cancel

Just to confirm, are you saying you got the CAC-1070 to work to the Sceptre u435cv 4k tv ?

  • Liked by
Reply
Cancel