DisplayPort 1.4 to HDMI 2.0a –> no [email protected]

Updated on 26-07-2018 in Adapters and Cables
6 on 20-07-2018

Hello,

using this adapter on my Ryzen 2200g-build (gigabyte ab350m-d3h) together with ubuntu 18.04 (latest mainline kernel –> 4.18-rc5 and latest mesa 18.2-devel and latest linux-firmware). With the adapter I can only use at least 30hz @ 3840×2160. 50Hz and 60hz does not work. If I connect the same TV (LG OLED) to the same pc (with same software) directly via HDMI 2.0 then I can select 50Hz and 60hz and it´s working. So the problem is related to the adapter.

Does anyone of use this adapter with linux and got 50Hz/60hz working?
Did you use a custom modeline for that?
Is maybe a newer firmware for the adapter available?

regards
Steffen

 
  • Liked by
Reply
1 on 23-07-2018

Good day Steo,

I will tell [email protected] to send you an email with latest firmware,

on 23-07-2018

Sorry about this, can you please send an email to [email protected] …
i cannot check your email 🙁

Show more replies
  • Liked by
Reply
Cancel
1 on 23-07-2018
thank you. Just updated to latest Firmware but max refreshrate is stil 30Hz at 3280×2160 in Linux.
50hz and 60hz still not visible only via direct HDMI Connection?
Any ideas how to troubleshoot that issue?
on 23-07-2018

It sounds like the system is not recognizing the Screens EDID at boot when connected via the adapter.

 

Normally making such a custom resolution will fix that problem, because you are effectively overwriting the system settings (or whatever the system thinks is good).

You don’t get the option at all to choose 50 or 60 Hz while making custom resolution ?

Show more replies
  • Liked by
Reply
Cancel
1 on 23-07-2018

I got 50Hz working with this custom modeline over the CAC-1080:
modeline “3840x2160_50” 445.008 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync

60Hz I could not get working. I tried About 20 different modelines without any success.

on 26-07-2018

Please keep your eye out for Graphics driver updates for Linux because i am quite sure that is where the issue comes from 🙁

Show more replies
  • Liked by
Reply
Cancel