Fed up with the fact the Club3D 1.2 to 2.0 adapter!

Updated on 12-04-2017 in Adapters and Cables
42 on 21-10-2016

I was working perfectly up until a few drivers ago. No I cannot get 60Hz at 4k no matter what I do! I refuse to go back to older drivers that won’t play recent games efficiently, especially after paying so much for the adapter.

I’ve tried the custom resolution fix and can onlt get 30Hz maximum out of it
I’ve tried the 8pc fix @ 4:4:4
I’ve tried all my TV settings and cannot find advanced colour or any other colour options that are specified in the “known” fixes.

please help!

 
  • Liked by
Reply
0 on 25-10-2016

Hi Spike Rules,
Unfortunately we have heard of more issues with the latest AMD driver in combination with “older”cards. Although the driver update 16.9.1 and newer seem to work fine for RX400 series, it does not seem to bring much for “older” cards.

I understand and respect that remaining at older drivers should never be the goal, but it can serve as a helpfull temparory solution. I know that AMD is working hard at getting all issue sorted, although they will never publicly make such a statement, i have never before seen so many Driver Updates in such a short time … Also our R&D and Factory are trying to source the isuse so parhaps we might be able to offer solutions.

It  should work just fine on Driver 16.8.3 you can find here:

http://support.amd.com/en-us/download/desktop/previous/detail?os=Windows%2010%20-%2064&rev=16.8.3

Will keep you posted on progress.

  • Liked by
Reply
Cancel
11 on 30-10-2016

AMD Drivers 16.10.3 (from 2 days ago)
R9 290x Vapor-X OC 8G
LG 43UH610V (Europe)
Win 10 – v1607
Club3D DP to HDMI 2.x adapter

Still not working at >[email protected]

Tried (in vain):
– Every HDMI Port
– Changing every color option I can find on the TV (Including extended color mode)
– Creating a custom res in AMD Settings (Clicking on “verify” resets it to 30Hz)

Eventually got back to AMD 16.8.3 to fix the issue, lets hope AMD doesn’t forgets us, there is not reason for a <2yo card to become obselete that early.

For Club3D’s staff: Did you contact AMD about this issue? Any answer yet?

on 31-10-2016

so far nothing from the AMD Camp 🙁

I will update as soon as we get feedback …

on 31-10-2016

Hello MST1407

I have the same problem as secu2. The adapter is not working at 60hz. I tried the older AMD Driver that you posted before. But it wont work 🙁

My setup:
powercolor r9 290x
Win 10 – v1607
Club3D DP to HDMI 2.0 adapter
HDMI 2.0 cable from Amazon basic
Hisense H43MEC3050 4K TV

Please help us 🙁

on 01-11-2016
Hello MST1407

I have the same problem as secu2. The adapter is not working at 60hz. I tried the older AMD Driver that you posted before. But it wont work 🙁

My setup:
powercolor r9 290x
Win 10 – v1607
Club3D DP to HDMI 2.0 adapter
HDMI 2.0 cable from Amazon basic
Hisense H43MEC3050 4K TV

Please help us 🙁From Matze92

Since you got hisense UHD, You need to connect your cable to either Hdmi 3 or 4 on the back of the TV. Hdmi 1 and 2 won’t work. I have a similar TV and everything is working fine.

on 03-11-2016

Hi Mohd.
We already tried to install older Updates and switched trough all the HDMI´s but it´s still not working.
Can you post your setting or do some pictures of them so that i can look what´s different between yours and mine?

on 03-11-2016
Hi Mohd.
We already tried to install older Updates and switched trough all the HDMI´s but it´s still not working.
Can you post your setting or do some pictures of them so that i can look what´s different between yours and mine?From Matze92

Hi Matze,

I’m using the latest AMD crimson 16.10.3 (see the picture) and everything is working fine (4k/60hz).

Firstly,Upgrade your TV to the latest Firmware (I’m using G0901 for hisense 55k3300). You must connect your Hdmi cable to HDMI 2.0 on your TV (check your TV Manual). Then go to your pc, hit right click on the window screen go to display settings, next click on Advanced display settings, scroll down and click on Display adapter properties. Now you will see your Graphic card name and click on List all modes. Choose 3840 by 2160 ,60 Hertz and  you should get 4k/60hz on your TV.

on 04-11-2016

Hi Mohd, this is all I have, open in new tab for better quality

on 04-11-2016

Hi,
1. I mean “Windows” display settings (see the first picture), click on it.

2. click on Advanced display settings

3. Next click on Display adapter properties

4. And finally, click on List all modes. Choose 3840 by 2160 ,60 Hertz and click apply (i’m using my laptop for taking the screen shot but it should be the same for desktop)

on 04-11-2016

Thanks a lot Mohd, it´s way better now =)
I´m glad you helped me with that.

on 04-11-2016
Thanks a lot Mohd, it´s way better now =)
I´m glad you helped me with that.From Matze92

 
I assume you got 4k/60hz signal on your tv, right ?.

You’re welcome

on 11-04-2017

Got some time today to update everything :
– Radeon Software Version 17.4.1
– Club3D Adapter Firmware 0x46
[email protected] Works fine now

on 12-04-2017

Cool good to hear

Show more replies
  • Liked by
Reply
Cancel
1 on 01-11-2016

Hello I am using the R9 Fury Nitro by Sapphire and have been suffering from this issue as well. I’m really disappointed with AMD at the moment. I was already annoyed enough that the HDMI port on the R9 Fury was only HDMI 1.4 and was very happy when I bought your DisplayPort->HDMI solution. But now that AMD has screwed up and rendered it useless with their new drivers my next video card purchase will without question be an nVidia card.

on 01-11-2016

Both companies have their flaws, do you remind the 970 memory scandal?

Show more replies
  • Liked by
Reply
Cancel
0 on 04-11-2016

I tried yesterday’s 11/3/2016 (16.11.1) driver hotfix from AMD and guess what… it still doesn’t work.

Just like in all the previous revisions, yes I am able to program my own custom resolution in the Crimson control panel.. but when it comes to playing games I get extensive flickering and odd visual artifacts like long lines that flash across the horizontal axis of the screen that are clearly because of some conflict occurring at the DisplayPort itself or during the signal conversion using the DP->HDMI 2.0 adaptor

I tried playing Rise Of The Tomb Raider and the colours looked mostly normal, and there was indeed improved performance.. but still these weird flickering lines appearing as a result of the the custom resolution and brokenness that has still not been addressed by AMD.

When I use this method to try and play Diablo 3 : Reaper Of Souls the game just looks hideous. All of the text in the game looks fuzzy and blurry, the colours are washed out and of course the flickering is still present.

Once I roll back to 16.8.3 drivers all these problems go away, all flickering gone, and no need to create custom resolutions in Crimson Software, all resolutions and refresh rates are available from the Windows Display Adaptor properties menu.

NB. There is nothing wrong with my GPU!!

I’m really starting to become exasperated with this issue. An investment into a top tier GPU like the R9 Fury should not have to suffer these frankly BS issues.

  • Liked by
Reply
Cancel
0 on 05-11-2016

Tried again with the 16.11.2 hotfix that just came out and yep.. still broken.

Rolled back to 16.8.3.. when will this end :/

  • Liked by
Reply
Cancel
11 on 05-11-2016
on 06-11-2016
From Mkfish

 
Download Display Driver Uninstaller (latest version)
http://www.guru3d.com/files-details/display-driver-uninstaller-download.html

You might have some corrupt files in your system so Display Driver Uninstaller should remove them. Once you download DDU click on “clean and restart” and your PC should restart in the safe mode and begin the uninstalling AMD driver. Once your done and back to normal windows screen, Install; the latest amd drive like you usually do and restart again. Then go to  “List all modes” in display settings and Choose 3840 by 2160 ,60 Hertz.

Good luck

 

on 06-11-2016

Done this over 10 times with different driver revisions greater than 16.8.3 and the highest refresh rate is always 1080/60hhz .. the rest is 2160p/30hz  🙁

Even after a fresh install of Windows 10

on 10-11-2016

Done this over 10 times with different driver revisions greater than 16.8.3 and the highest refresh rate is always 1080/60hhz .. the rest is 2160p/30hz  🙁

Even after a fresh install of Windows 10

From Mkfish

 
Ok Try this.

1. Download AMD/ATI Pixel Clock Patcher
2. Run atikmdag-patcher.exe
3.If all limits are found, click “Yes” to patch and sign. If a limit is not found or if multiple matches are found, the patcher needs to be updated.
4. Reboot.
5. Add custom resolution via AMD driver control (ccc), 3820*2160, 60hz, timing (CVT-RB).

https://www.monitortests.com/forum/Thread-AMD-ATI-Pixel-Clock-Patcher

on 14-11-2016

HOLY **** BALLS THIS ACTUALLY WORKS!!!!!!!!!!!

Thank you so much.

Now running 3840×2160 @ 60hz – No flickering or weird scan lines!!!
Diablo 3 RoS @ 2560x1440p @ 60hz – Everything working perfectly, colours fine, text is fine, everything is fine and NO FLICKERING!! 😀 😀 

Oh this is a joyous day indeed!

On 16.11.3 Hotfix drivers

 

on 14-11-2016

What worked for you? I’m getting blinking black screen with my new tv! Did the pixel patcher thing work?

on 14-11-2016

Yes update your drivers, create the custom resolutions you require. Then run the pixel patcher, restart and enjoy!!

on 14-11-2016

Didn’t work for me:(

on 14-11-2016

When you say it didn’t work what do you mean? Did the pixel patcher fix and sign your drivers after finding the limits?

on 14-11-2016

I did as stated above and the picture still flashes to black every other second

on 17-11-2016
I did as stated above and the picture still flashes to black every other secondFrom spikerules

 Tell us more about your setup

on 19-12-2016

Would just like to come back in and state that even though the pixel patcher fixed problems with latest drivers and custom resolutions in Diablo 3 (2.4.2) it did not however fix the  annoying flickering lines in games like Fallout 4, Rise Of The Tomb Raider or GTAV… So I’m back to being pissed off.

Show more replies
  • Liked by
Reply
Cancel
5 on 23-12-2016

Can Confirm: Running 4k60 on Latest 16.12.1 AMD Driver using R9 Fury
Oddly enough I haven’t defined a custom resolution.
Using a samsung ue40ku6000 
Standard Picture mode, UHD HDMI colour set to ON

on 29-12-2016

UPDATE: No longer working, for no apparent reason.

on 07-01-2017

UPDATE 2:
Having to cycle HDMI UHD colour mode Every time I connect to my TV, then set custom resolution which seems to revert to CVT but without reduced blanking. 
Previously stated I hadn’t defined a custom resolution, turns out AMD tweaked the UI and changed where you see the custom resolutions

on 09-01-2017

I hear 16.12.2 is working quite well for R9 290 / 390 / Fury X (apart from the 16.8.3)

on 10-01-2017

16.12.2 seems to be working nicely in order to get 4K/60Hz using custom resolution (reduced blanking)

However it’s a different story when you want to add say 1440p which I have been trying to do… When I switch to 4K/60hz the screen does this kind of “wipe” thing where a bar will wipe either up or down the screen (syncing the timings or whatever I dunno) and after this happens all is well and you know the adaptor has kicked in and is working.

When I add 1440p resolution this doesn’t happen though and I’m left with a less than great quality image, with a bizarre thin flickering line that seems to appear and disappear at will at the bottom of my display; I tried to record the flicker using Bandicam and when I watched the recording back there was no flicker. So I’m pretty sure this is not a driver issue or else Bandicam would of picked it up. 

It just seems to be one thing after another with this crap. My R9 Fury Nitro isn’t capable of playing all games at 4K and so 1440p is just as important to me as 4K… Still no closer to ending this nightmare. 

on 10-01-2017

Just read that my TV doesn’t support 1440p natively… but yet bizarrely in the 16.7.3 driver it has no problems whatsoever with 1440p. 

So looks like the saga could be drawing to a close to most of you 🙂 

Show more replies
  • Liked by
Reply
Cancel
3 on 16-03-2017

Still no fix for this? I’ve been reading about firmware updates, so why wasn’t everyone on this post contacted? We were the ones to bring this to your attention and still no respect? I put faith in this company and this product and paid a premium for the cable when first released. Some customer support and respect would go a long way to keeping customer faith you know!

I would appreciate a link to this “firmware update” please!

on 16-03-2017

Hi Spikerules,

What driver are you currently using and what Grpahcis Card you have exactly ?

I know many users of AMD Radeon HD and R7/9 2xx/3xx cards have been able to solve their driver issues with driver relaeses after 16.12.1.
So drivers from 16.9.1 ~16-12.1 please dont use for AMD Radeon HD and R7/9 2xx/3xx cards. After that you should be fine.Settign to make custom resolutions with Timing Standard for CVT-Reduced Blanking are back …

on 16-03-2017

I tried ALL versions of the AMD drivers since the problem began and none fixed my issue. I tried setting up a custom resolution too. I tried all attempted fixes and none worked. All I was told was to roll back to the drivers that worked from early last year! Which is a ridiculous “workaround” seeing as AMD release game optimised drivers all the time. In fact the latest ME game, which I am currently running via Origin Access early REQUIRES you install the latest AMD drivers.

I have an AMD Nano and 4k HDR Samsung KS8000 TV.

on 16-03-2017

You also tried the custom resoltuion with Timing Standard set to CVT-Reduced Blanking right ? That often works best for setups with TV’s.
So that would then be Custom resolution for 3840x2160p at 60Hz with Timing Standard set to CVT-Reduced Blanking and BPC set to 8Bit and turn on the UHD Color on the TV. If that does still not work, the only thing i can think of is the Pixel Clock not being correct.
Sometimes the EDID info cannot be read in good manner, resulting in a Pixel Clock setting being send out by the system, which the TV does not support.Also please make sure to keep software of the TV updated.

You should can do such setting with a progrma like CRU:  http://www.monitortests.com/forum/thread-custom-resolution-utility-cru

Since you have a very good TV it will most probably support a pixel clock of 594MHz
and it could be that it will be standard set to something like 540Mhz …

I know that CRU helped already quite a few users with 6000 series TV’s …

Show more replies
  • Liked by
Reply
Cancel
2 on 16-03-2017

Newest firmware release will be send out by [email protected] today.
Also requested the memebers of this threat to be placed on the list for future updates, so those will come automatically your way.

on 16-03-2017

It now works after adapter firmware and AMD crimson driver update

on 16-03-2017

cool good to hear it is (finally) working for you !

Show more replies
  • Liked by
Reply
Cancel