CAC 1073 issue.

Updated on 05-07-2018 in Adapters and Cables
4 on 03-07-2018

Hello everyone, I bought a CAC 1073 cable a few months ago (DP 1.2 to HDMI 2.0 cable, the one with two different ends) and it worked flawlessly for the first weeks. I used it with a Samsung 4k TV KU7000 model (AKA model KU6400 in my country) with my AMD R9 390X card, but since the TV stays in the living room, I ended up not being able to leave my PC there connected, having to move back to my room, where I use a 1080p LG TV LB6500 model as my monitor.

Since the CAC 1073 cable has an HDMI end, to save time I ended up hooking up the same CAC 1073 to the LG TV in my room. At first, all went well, working as intended. But in the same week, randomly, the cable just stopped working. It has no video output, nor shows anything connected on both TVs. Time went by, I ended up forgetting about it, but now I found the cable again going through my stuff and decided to give it another go, sadly with no success again.

 

I’ve been reading a lot about DP related bugs, learned about the “unplug everything, wait few minutes and try again” procedure, but no matter what I do, the cable simply won’t work anymore. And now I’m stuck in quite a situation, where I don’t have any other DP cable, don’t have any DP monitor and don’t have any other DP exit on my gpu. The other two ports (HDMI and DVI) works normally, issue seems to be with the cable or the DP exit itself, I really just don’t know.

 

After I found this forum, I saw something about firmware updates, is it possible that a firmware update could solve this issue? Is there anything you guys could do to help me?

 

Thank you for your time.

  • Liked by
Reply
3 on 03-07-2018

<I tried to edit my post but it didn’t worked, terribly sorry for the double-posting> 

PS: I’m using Windows 10 Pro x64 latest build and AMD Adrenalin 18.4.1 Drivers, although back then I was using different versions of both and still had the issue. Also, since that day I’ve probably formatted my PC about 2 or 3 times.

on 03-07-2018

Good day camargo009,

Sorry to hear this.
It can of course be that the cable is defective in which cas you should warranty form the place of purchase.

Iw ill have [email protected] send you an email with frimware for the cable in case it is not already loaded on the Cable Adapter.

on 03-07-2018

Thank you for the response. 

I’ve checked my email and found the instructions. Things were progressing, I picked the V7.55 because I do own a Haswell cpu, but when I choose AMD on the AuxUpdate program, it says “No graphic card found”, which is crazy.

Regarding warranty, unfortunately for me there is no registered or official distributor for Club3D products here in my country, which means I had to resort to an independent seller on MercadoLivre (a buy/sell website like an eBay that is very popular here), and he gave no warranties on the product other than replace the cable IF it showed any issues by the time it arrived, but, like I said before, it worked flawlessly for the first weeks, so there is no way really for me to get this replaced, at least not in my country.

 

I found a similar product from Dell, available on their own website here in my country (with proper warranty), for significantly cheaper than what I paid for this cable, but the situation I’m in it’s quite complicated: since I have no way of testing either component separately (the gpu’s DP exit or the cable itself) I can’t really stop thinking it might be a faulty gpu, in which case I would spend more money in stuff that still won’t do me any good. That’s why I have to be sure what is the problem.

Do you really think that me hooking it up to a normal 1080p TV with 1.4a instead of 2.0 could have broken the cable? But then wouldn’t the TV’s HDMI connection used at the time be faulty as well?

 

Once again, thank you for your time.

on 05-07-2018

Hi camargo009,

Do you really think that me hooking it up to a normal 1080p TV with 1.4a instead of 2.0 could have broken the cable?
No

The only 2 reasons why the Updater program wuold give the error “No graphic card found” is when the adapter is not connected to the Graphics Card with Screen connecte dto the Adapter and turned on. Or when you system has Dual Graphics and the updater program gets “confused” becuase it detects different graphics in the system.
Please check in the Bios on the mainboard if the Integrated Graphics is disabled, if not please do so.
Did the clean Driver installation not make any difference?

Show more replies
  • Liked by
Reply
Cancel