CAC-1080 Backwards compatibility.. Windows 7 Drivers?

Updated on 21-12-2018 in Adapters and Cables
1 on 21-12-2018

Hello, I tried a CAC-1080 I received today, and it would not display any picture. I have a few HDMI 2.0 cables, so I know that’s not the issue coming out of the adapter. I am wondering if CAC-1080 (that mentions DisplayPort 1.4) isn’t backwards compatible with DisplayPort 1.2 as my PC is? Or are there Windows 7 drivers I might need to install for the adapter or should it just be plug and play (lists Windows 10 on the website). I’ve tried different graphics driver versions, all the different ports on the TV, switching HDMI 1.4>2.0 on and off, etc, etc. and cannot get the option for 60Hz.

Some background on the situation and the reason I am needing to use an adapter in the first place is the PC only has HDMI 1.4 port, which can only support 3840×[email protected] in order to achieve 60Hz I need to find a way to use the DisplayPort output.

My setup is as follows:

Intel i5-7400 running Windows 7 Ultimate with Intel HD630 Graphics : Supports DP @ max 4096×[email protected]
https://ark.intel.com/products/97147/Intel-Core-i5-7400-Processor-6M-Cache-up-to-3-50-GHz-

Monitor/TV Sceptre/Komodo KU-555 : Supports 3840×[email protected] with HDMI 2.0 inputs
https://www.walmart.com/ip/Komodo-55-Class-4K-Ultra-HD-2160P-LED-TV-KU-555/858916785
http://www.sceptre.com/

Please let me know if you need any further info. Thank you

 
  • Liked by
Reply
0 on 21-12-2018

Hello MRC00I88,

It sounds like the system does not recognize the EDID coming the adapter from screen at boot up. Normally a good work around that would be to make a Custom resolution in the graphics driver.

In general

  • Setup

Setups with TV’s normally work best by making a custom resolution, 3840*2160 at 60 Hz with Timing Standard set to CVT-RB (Reduced Blanking).

(For setups with Monitors Timing Standard can remain on “auto”.)

On most TV’s you will need to do some settings like “Enhanced Mode”/ “PC-Mode” and/or “UHD Color” for the HDMI 2.0 port in use. 

Please make sure the HDMI port of the Screen/TV supports 4K 60 Hz, often not all HDMI inputs support that.

Please make the HDMI Cable you are using, supports 4K 60Hz / 18Gbps.

 

  • Custom Resolution Intel Graphics Software

Making that Custom resolution in the Intel Graphics Driver should be something like this …

Open Intel Graphics Control Panel, choose “Custom Resolutions” (left bottom option) It will ask you if you wish to continue; YES
Standard the “Basic” setting is shown, click on “Advanced”, make sure you make this custom resolution for the correct screen (left bottom)
Fill in; Width 3840; Height 2160; Refresh Rate 60 ; Set Timing Standard to CVT-RB for use with TV (and for use with Monitor you can leave that on “Auto”). 

If possible, please set Color Depth BPC to 8 Bit. and click on “ADD” on the right bottom of the window. Now this resolution I added to the system and can be chosen. 
Go back to “General Settings” (left top), it will show the basic options and here you can now choose the 3840×2160 resolution at 60Hz. 
(You might need to so a reboot first)

Regards

 

  • Liked by
Reply
Cancel