CAC-1080 not passing surround audio

Updated on 06-07-2018 in Adapters and Cables
5 on 01-07-2018

I just purchased a CAC-1080 DP1.4 to HDMI 2.0b adapter and I am unable to get it to recognize anything other than stereo 2.0 audio.
I am using Windows 10 Pro Ver 1803 build 17134.112 with an MSI GTX1080 video card. I am using Nvidia 398.36 drivers ( and tried older drivers as well) through a Yamaha RXA2070 receiver.
If I take the same cable and move it to the HDMI port on the video card, I get all the surround options in the Windows sound configuration screen, but when I swap it back to the CAC-1080, the only option is 2.0 stereo.
I have done a bit of detective work and it appears to have something to do with the EDID info. It seems to be stripping the receiver info out when attached to the adapter.
Do you have any suggestions?

Thanks!

  • Liked by
Reply
0 on 02-07-2018

Good day Joeoboe,

That “8 Channel Audio  data” is in the first EDID Block that aparently is blocked.
Since this does not happen with other graphics (intel Integrated or AMD) it looks like an Nvidia issue.
Did you already try with a 390 driver (the 391 drivers will not help, we tested those already and seem not very stable).?
Please also check for Bios update for the GTX 1080.

  • Liked by
Reply
Cancel
0 on 03-07-2018

OK, I have the latest bios and spent the day trying a variety of drivers from the past 2 years. None of them worked.
I DID find a work around. In my sound setup screen it showed 2 channel stereo, and it had an option to install Dolby Atmos for home theater. So… I installed that from the windows store and it allow me to have surround. I still have the 5.1 and 7.1 options greyed out, but the surround works, as I confirmed it with a variety of Dolby Atmos test videos.
However, I discovered ANOTHER issue. HDR works from my HDMI out of the video card, but NOT with the CAC-1080 adapter. I am wondering if there is something wrong with this particular adapter. Is there a new bios I can load for this adapter?

  • Liked by
Reply
Cancel
0 on 05-07-2018

Hi Joeoboe,

I will have [email protected] send yo an email with latest firmware.

  • Liked by
Reply
Cancel
1 on 05-07-2018

Thanks! I had an older firmware 11.091.000 and the new one is 11.116.001. This fixed it. HDR is now working! Thanks for the great customer service!

on 06-07-2018

Great 🙂
Thanks for the feedback

Show more replies
  • Liked by
Reply
Cancel