CAC-1085 needs constant power cycling to show image

Updated 24 hours ago in Adapters and Cables
3 on 22-07-2020

I am having issues with this adapter using a Club3D “10K” 2m cable. I have a 2080 Ti and when setting my LG CX 48″ OLED TV to 4K 120 Hz 8-bit, it will often instead show a garbled 1920×2160 resolution. Power cycling the adapter is required to fix this.

Power cycling the adapter seems to be required for anything related to resolution switching whether it’s toggling HDR, changing resolutions, refresh rates etc.

What gives?

 
  • Liked by
Reply
0 on 30-07-2020

Hi please send a mail to [email protected] they may be able to help you with this issue 

  • Liked by
Reply
Cancel
0 1 day ago

I seem to have  the same issue. When I turn on the tv (CX 48), the display is messed up, and the tv reports it as [email protected] (YCBR420 8b TM). Should be [email protected], RGB8. 

I can get around this by turning the ultra hd deep color mode off and on again on the tv. After this, the picture always works and the tv reports it as [email protected] (RGB 8b 4L10). 

I tried asking support for info/firmware, but nothing yet. Also downloaded firmware and update tool from july (version 3f), but the issue remains. Hopefully there is a more recent firmware that manages to get the resolution/timing right without issues. 

GPU is 2080TI, TV is a LG CX and I am using a 48Gbit rated cable. 

  • Liked by
Reply
Cancel
0 24 hours ago

Also seems to happen when changing resolution. 

  • Liked by
Reply
Cancel