CAC-1085 wont work at 4:4:4

Updated on 14-06-2021 in Adapters and Cables
11 on 29-04-2021

Hello I just bought a CAC-1085 and a 6.5 ft officially certified HDMI 2.1 cable. I am using a Radeon 5700XT and a LG CX 48″ OLED.

When using the adapter the display is being connected at the same speed as the HDMI port directly on the GPU. The adapter is only doing HDMI 2.0b. I can do 120hz but it goes to 8 bit 4:2:0. This is the same exact thing I get if I just plug the hdmi right into the gpu.

How do I fix this? I tried a 10 ft officially certified cable and it didn’t work then I saw the manual says to use one under 6.6 so I bought this cable and it is also not working. Should I try a 3 foot cable? 

I know for a fact this works I have seen many people say this exact set of hardware works. I read something about using CRU(custom resolution utility) to force the tv to use 4:4:4 because it’s just an identification problem? 

Please help there is absolutely no way to buy a HDMI 2.1 graphics card, there hasn’t been even one in stock for even one minute in the last 6 months I check all the time and besides I love this gpu, and I cannot return my display which cost $1400. I only bought it because I found your adapter. 

  • Liked by
0 on 29-04-2021

I see there is a firmware update that another user mentioned that fixed all his problems withh the 5700xt and this adapter but I cannot find it anywhere for download. Can someone please post it here? 

  • Liked by
0 on 30-04-2021

HI Chaoskid,

Please email [email protected] with the above question, pretty sure they are happy to help. 🙂

  • Liked by
5 on 03-05-2021

I did and they sent me the firmware but it didn’t change anything. I can do 4k 120hz 4:2:0 8 bit or 4k 60hz 4:4:4 HDR but no 4k 120hz 4:4:4. Didn’t hear back after that.

The adapter just doesn’t want to do hdmi 2.1 or maybe it’s an AMD problem but I’m only getting hdmi 2.0b bandwidth. I’m not sure what else to try.


on 03-05-2021

What hdmi 2.1 cable do you use? And is that Cable certified to do 48GBps?

I don’t know but just speculating here, it does look like you are either using a HDMI 2.0 cable or there is something in between the GPU and TV. Are you connecting trough a soundbar and then to the TV? Have you tried connecting it to HDMI port 2. Which is eARC I believe.

Have you tried and connecting the USB power to a different port or maybe external?

Could you add a picture of the adapter? Maybe you received the CAC-1080?? Again just speculating I don’t know 🙂 just trying to help.

on 07-06-2021

You’re not the only one experiencing this with a 5700 XT. I’m running a 5700 XT, LG CX 48″, and Zeskit 48 Gbs HDMI cable and am experiencing the same thing.


There is an ongoing thread on AMD’s forums discussing this:


Club3D’s response seems to indicated that there are some variant’s of the 5700 XT that aren’t DisplayPort 1.4 (HBR3) compliant and are incapable of 32 Gbps (8.1 Gbps x 4). AMD support claims this is not the case, but I don’t have the hardware to verify it one way or the other.


I also updated the CAC-1085 to the lasted firmware provided by Club3D, and while that resolved some flickering I had it did nothing to convince my GPU to output 32 Gbps…

on 08-06-2021
Hi Xeotion,
I’ve read the thread you posted, very interesting.
I wonder… why has no one tried a direct DP1.4 connection yet? That should immediately tell you if the port is able to transfer the 32Gb/s right? Or 4x 8Gb/s.
Without the adapter with a display supporting DP1.4 and of course a cable being DP1.4.
I have an 5700XT and a LG 27GN800-B and DP1.4 cables. I check tonight if every port is able to push 32Gb/s. I will also test it on a BenQ El2870UE.
on 13-06-2021

Thanks for the reply Baak,

Mine is just a hardware limitation. I don’t have access to a DisplayPort 1.4 capable monitor.

I’m interested to hear the results of your test! Were you able to get 32 Gbps out of all the ports?

on 14-06-2021

Truth, I have not tested it yet. The weather was to nice to sit behind my desk checking cables 😛 Will do asap and will let you know.

Show more replies
  • Liked by
0 on 12-06-2021

The AMD software tells you the link rate and lanes but it doesn’t tell you if DSC is supported and enabled. It would be helpful if the software reported more DisplayPort info from the DPCD registers like the AGDCDiagnose command does in macOS. The AMD software shows current link rate and lanes but doesn’t show supported link rate and lanes or the info about DSC. It doesn’t show info about MST hubs either (MST topology, etc.) or HDCP, etc.

I have a W5700 and I believe it supports DSC as I was able to use a MST Hub to connect three 4K displays at 4K 60Hz 8bpc RGB (that’s 533MHz pixel clock x 24bpp x 3 displays = 38 Gbps which is greater than the 25.92 Gbps that HBR3 can do without DSC (8.1 Gbps x 4 x 8b/10b).

The first screenshot in the AMD forum is using 4:2:0 chroma sub sampling which is a lossy compression method with a 2:1 compression ratio. (actually, it just throws away three quarters of the chroma components) 
1188 MHz pixel clock x 8bpc x 3bpc x 12c/24c = 14.25 Gbps.
1188 Mhz is the expected pixel clock for 4K 120Hz (4K 60Hz HDMI is 594 Hz and 120Hz is twice that).
DisplayPort HBR2 x4 is 5.4 Gbps x 4 x 8b/10b = 17.28 Gbps.
That means DSC is not being used.
HDMI 2.0b is 14.4 Gbps (6 Gbps x 3 lanes x 8b/10b) so it appears HDMI 2.1 is not being used.

The second screenshot in the AMD forum community post must be using DSC (a visually lossless compression method):
1188 MHz pixel clock x 12bpc x 3cpp = 42.768 Gbps.

Ok, so either the limit is HBR2 or HBR2 is being used because 4:2:0 is being selected with 8 bpc. You have to break the HBR2 barrier by switching to 12 bpc. That will get you into the HBR3 range. Then you need to break the HBR3 barrier by also enabling 4:4:4 to get into the HBR3+DSC range (required to get into the HDMI 2.1 range). None of that will be possible if a piece of the software thinks there’s a HDMI 2.0 barrier (because HDMI 2.0 has less bandwidth than HBR2 x4).

CRU could be used to remove the 4:2:0 options. I don’t know if that would get you into the HDMI 2.1 range though.

  • Liked by
1 on 13-06-2021

Hi joevt,

I agree with all of your conclusions. Unfortunately, when using the adapter I was unable to select anything other than 8 bit 4:2:0 and 120Hz simultaneously via AMD software. So there would be no way to attempt your recommended troubleshooting method from what I can tell. I did attempt to force enable DSC via CRU, but none of the options outside of HDMI 2.0 or HBR2 ever showed up as usable options.

I never did remove the 4:2:0 options via CRU however… At this point, I have returned the adapter and largely given up on the pursuit.  

on 14-06-2021

The DSC that you want to use would be on the DisplayPort side. That would not be affected by the EDID since that info is in the DisplayPort DPCD.

There’s DSC info in the EDID for HDMI 2.1 (see the edid-decode project) but it’s not needed for 4K 120Hz which requires less than the 48 Gbps. Oh wait, above I said 4K 120Hz 12bpc 4:4:4 is 42.768 Gbps. HDMI 2.1 has a max of 42.67 Gbps (for 48 Gbps connection; 35.56 Gbps for 40 Gbps connection). So it seems DSC is required on the HDMI 2.1 side as well in that case. DSC is not required from HDMI 2.1 (40 or 48 Gbps) for 4K120 10 bpc 4:4:4 though.

Show more replies
  • Liked by