CAC-1170 not getting Full RGB range

Updated on 27-12-2016 in Adapters and Cables
8 on 20-12-2016


I Got my CAC-1170 adapter and got 4k @60Hz working on my Intel Graphics 4600, but I can’t select the option to change from limited RGB range to full.

When at 4k @30Hz, I’m at full RGB range but @60Hz it seems like it’s at limited RGB range. Or do it have to do with RGB 4:4:4?

If so, Intel have the color mode locked at 32bit TrueColor. (it might have something to do with later versions of Windows than Windows 7. Windows 10 is 32bit color, and you have to use compatibility on a shortcut to an app)

Also options in Intel’s control panel turns out blank when I use the CAC-1170.

General settings the advanced tab is blank.

While in the Color settings tab, I get the Hue & Saturation options instead of the YCbCr option.

It seems @30Hz the picture is more vivid, while @60Hz the picture is a bit washed out looking? Is there a way to fix this?

CAC-1170 came with firmware V7.26, is there a newer firmware? If so, may I have it please?

Can I also have the previous firmware before V7.26, too?

I’m using an Hisense 50H6C (50CU6000) TV, and HDMI 2.0 cable from AmazonBasic (connected to HDMI port 3 in back of Hisense TV).

  • Liked by
7 on 20-12-2016

Hello Xumarice, which CPU you have in the system ?
We do have newer firmware, however i am not convinced this will solve your issue, i will have that send it over by email from [email protected].
With TV’s it normally works best to make a custom resolution for 3840x2160p at 60 Hz with Timing Standard set to CVT-Redeced Blanking (RB). You will have to make that in the Intel Control panel advanced settings first for the correct screen, before you will be bale to select that option. Sometimes also requires a reboot.
What Graphics Driver version are you using ?

on 20-12-2016

Hi, MST1407

I have an Intel i7-4720HQ CPU.
If I do a custom resolution for 3840x2160p @60Hz with Timing Standard set to CVT-Reduced Blanking (RB), then audio will not work. Yet even using CVT-Reduced Blanking (RB), I get the washed out coloring.
I had to make a DTD in regedit to get audio and exactly 60Hz. I used Modeline: “3840×2160” 534.01 3840 4016 4040 4064 2160 2168 2176 2188 +hsync +vsync.

I’m using Graphics driver version:, installed manually through device manager.

on 20-12-2016

Hi Xumarice,
I tested with Intel Graphics Driver pack, I know it is not the latest, but It
worked very well for me where i also had sounds issues with newer drivers.
Please also check for Software update for your HiSense TV.


on 20-12-2016

I’ll downgrade to driver and see if it works.
Been waiting for Hisense to email me back for a firmware update, if there is one.

on 22-12-2016

Downgrading to driver didn’t work, nor did the flashing to a newer firmware work. Hisense has no firmware for my TV.
But when taking a look at this:

So I need to set colour depth to 8bit/bpc to get 4:4:4? Not sure how to do this on Intel since I only get the 32bit option. Windows 8 and up only use 32bit colour as I read.

on 22-12-2016

That is Bits Per Pixel (BPP) you are talking about. This grpahcis show Bits per Color (BPC), not the same thing. And i dont think Intel will give you the option to do setting on the BPC.

on 23-12-2016

I started to notice that at 30 or lower herz, I have finer detail in color. Yet going over 30Hz to 60Hz, I lose color. Going to 120Hz, I lose even more color.

So, is this what happens using a higher refresh rate, the cost of lost in color? I have to lower gamma to 0.9 and saturation to 24 to get back some color that I lost.

on 27-12-2016

Within the boudries of what the adapter can handle, that would be depending on the capability of the system and normally mainly on what the screen can handle …

Show more replies
  • Liked by