CAC-1500 not working

Updated on 03-10-2018 in USB Type C
3 on 02-10-2018


i have a problem whit the CAC-1500.

Even after all Windows update(no drivers down-loadable!)

The device shows up for a sec in device manager and disappears again, i have 2 of those adapters so both are dead or their is something wrong whit my system, but i also tried another system still no result tried other network nothing!

Please maybe driver problem but I can’t download the thing anywhere of your website.

Kind regards,


  • Liked by
0 on 02-10-2018

Dear Richard,

Sorry to hear this,

The chance that you have 2 of the same products which are both defective is very, very small. 

There is no driver for the CAC-1500. The adapter makes use of the standard USB Ethernet driver that is integrated in Windows. So there should be no need for driver installation.

The CAC-1500 is equiped with the RTL8153AD-CG Chip, and you can find drivers here:

It uses [email protected] max of power, which is normally standard provided by the USB C port.




  • Liked by
1 on 03-10-2018
Thanks for the quick response! this solves the problem!
on 03-10-2018

Good to hear and thanks for hte feedback 🙂

Show more replies
  • Liked by