CAC-1510 does not display in full resolution

Updated on 09-04-2020 in Adapters and Cables
1 on 08-04-2020

Hi, I just purchased a CAC-1510 in order to adapt my USB-C port of my 2017 non-touch bar macbook pro for use with an Apple Cinema HD Display (30″). The adapter only allows me to use 1280×800 resolution and no amount of ‘holding the option key and selected Scaled resolutions’ will reveal higher resolutions than 800p. Upon inspection of the USB devices section within system report, it appears the adapter only connects via the USB 3.0 bus, not 3.1. Is this a firmware issue with the adapter? How can i resolve this. I’ve tried:

  • Holding the option key to display additional scaled resolutions once clicking the ‘scaled’ button;
  • Resetting SMC / NVRAM / PRAM / anything else that can be reset from those guides;
  • Disassembled and inspected the USB-C connectors, given a clean and reassemble my MacBook Pro;
  • Installed a clean version of High Sierra to ensure it isn’t a software problem (with the same result, now installed back to 10.15.4 using a time machine backup);
  • Deleted a display .kext file from Library/Preferences/ and rebooted the machine to no avail;
  • Used the options modifier key for the display scaling in safe mode and switched back to normal boot.


  • Liked by
0 on 09-04-2020


my advise is contact Club3d support.

[email protected]

since you’ve tried all the solutions i can think of directly.

  • Liked by