CSV-1550 doesn’t resume / wakeup

Updated on 20-04-2020 in MST Hub
8 on 11-04-2020
 
  • Liked by
Reply
1 on 11-04-2020

I have a Lenovo T-580 Laptop with i5-8350U running Windows 10 build 1809 with latest drivers.  The T580 has two USB-C ports.  One is connected to a CSV-1550 MST hub, which is driving QHD and WUXGA 60Hz displays.  The other USB-C is driving a [email protected] display. Everything works fine after hitting the reset button on the MST hub, but there are a couple of problems.

1) When Windows turns off the displays after detecting inactivity, the MST won’t wakeup/resume.  I press a key or shake the mouse to wake up the system and the 4k display wakes up, but the displays connected to the MST hub don’t turn on.  I have a to hit the reset button on the MST to get them to turn on.  How do I get MST to wake up/resume automatically?

 

2) After using the system for several hours, sometimes the MST monitors start flickering simultaneously (go blank for several seconds then come back).  The 4k monitor stays on.

 

I used the same setup and cables from a loaner Lenovo Ultra Dock (40AJ), which uses the same USB-C ports and has a MST hub inside it and didn’t experience either of these problems.

 

The device manager shows an Unknown USB device (Device Descriptor Request Failed).  I didn’t check to see if they unknown USB device was present.

on 13-04-2020

Hello,

Could you send a screenshot of the device manager?
Wake up after sleep is windows based.
Please try the following.

1. Troubleshoot Power
Type troubleshoot in Cortana Search > Click Troubleshoot > Scroll down > Click Power > Run the troubleshooter > Follow on-screen direction.

2. Restore Default for Power Settings
Windows Key+i > System > Power & sleep > Click Additional power settings to open Power options > Click Change Plan Settings > Click Restore default settings for this plan

3. Disable Fast Startup
Reach to Power options as in previous step > Click Choose what the power buttons do > Click Change settings that are currently unavailable > Scroll down to Shutdown settings and uncheck Turn on fast startup > Click Save changes

4. Action for Battery Drivers
Windows Key+X > Device Manager > Expand Batteries > Right-click on first entry below
Disable device > Wait for 10 to 20 seconds > Enable device (you will need to do this for all entries one by one)

5. Also update your BIOS to latest from computer maker’s site.

Show more replies
  • Liked by
Reply
Cancel
1 on 13-04-2020
on 13-04-2020

Hello,

It seems there are no faults in the device manager. If there was a fault a yello warning triangle would appear.

Have you tried the multiple solutions that are given to you? In my previous message?

Show more replies
  • Liked by
Reply
Cancel
1 on 13-04-2020

None of the steps helped.  I performed steps 1 and 2.  Fast start up in step 3 was already disabled, so nothing to do there.  For step 5, I already have the latest BIOS installed from Dec 2019.  I performed step 4 without rebooting.  Is the reboot necessary? 

Another problematic scenario I just discovered is the MST doesn’t wake up when I plug it in.  I removed the laptop from my desk over the weekend and used it elsewhere.  When I came back to my desk this morning and plugged in the MST and 4k monitor cables, the MST didn’t wake up.  The 4k monitor did wake up. I had to hit the reset button on the MST to get it to turn on.

on 13-04-2020

The reboots are neccessary.

What do you mean with the mst didn’t wake-up since there is no sleep function on the MST-hub. Is your windows completely up-to-date?

Show more replies
  • Liked by
Reply
Cancel
1 on 18-04-2020

The reboots didn’t help.  Windows is up to date.

 

on 20-04-2020

Hi,

according to the Lenove specs the USB-A port is always on. the same setup should be available for the USB-C port.

My guess there should be a possibility to turn this on for the USB-C port in the Bios of the laptop.

in conclusion this issue seems to be with the notebook not the CSV-1550, my advice is to contact Lenovo and ask for advice on how to keep the USB-C port in always on mode.

Show more replies
  • Liked by
Reply
Cancel