CSV-1564W100 frequently disconnects certain USB peripherals

Updated on 14-09-2021 in Docking Station
4 on 11-09-2021


I recently purchased a CSV-1564W100 docking station for my XPS 17 9710. I am only using the hub (which is disconnected from power), and am using an independent charger as I understand that this docking station’s power wattage isn’t high enough for the laptop. I have, however, tested my issue both WITH and WITHOUT power to the docking station– no differences observed.

I have, plugged into the docking station, a 1080p60 HDMI display, a 1080p DP display, ethernet, speakers, and several USB-A peripherals: a mouse, a keyboard, a numpad, a drawing tablet, a microphone, and a webcam. Some of the peripherals are connected to an additional external hub (4 USB-A => USB-A), though swapping those around haven’t affected anything (in other words, connecting the mouse directly to the docking station doesn’t make a difference from connecting it to the external hub).

Several times throughout the day, certain peripherals, such as the keyboard and the mouse, will simultaneously disconnect from my laptop (the cursor freezes and the keyboard becomes unresponsive).

In addition, unplugging and replugging any of the peripherals does not resolve the issue, and unplugging and replugging the docking station exacerbates the problem. In the latter case, the mouse and keyboard still won’t work, though sometimes the monitors will disconnect as well.

I have unticked “allow computer to turn off this device” on all USB device drivers in the device manager.

Restarting the computer generally solves the issue, though that’s not a long term answer to why this issue exists and the steps I might be able to take to resolve it.

Any assistance would be appreciated.

  • Liked by
0 on 11-09-2021

Sorry, I forgot to mention that I have also tried the docking station on another, older XPS, to no avail. I have also tried plugging in my mouse and keyboard using a smaller 4USB-A => USB-C hub successfully, which convinces me that the issue is in the docking station.

  • Liked by
2 on 13-09-2021

Hi TripleSteak,

Just to be sure, you have an additional 4 USB-A -> USB-C hub connected to the CSV-1564?

It might be that all those peripherals combined are drawing to much power from your Laptop in total.

Have you tried troubleshooting 1 by  1 adding the peripherals?

on 13-09-2021

Hi Baak,

I had tried disconnecting everything but a mouse and keyboard, and the same issue still persisted 🙁

The problem didn’t occur when I used the 4USB-A => USB-C hub, so I ended up returning the docking station yesterday.

Thanks for the help though. Cheers!

on 14-09-2021

HI TripleSteak,

Fair enough. Thanks for letting it know 🙂

Show more replies
  • Liked by