M1 iMac with 30-inch cinema display

Updated 2 days ago in Adapters and Cables
6 on 26-08-2021

Hello all,

Just got the CAC-1510-A to connect a M1 iMac with the 30” cinema display. Unfortunately I haven’t been able to get the proper 2560×1600 resolution, even while holding down the option key prior to choosing a resolution. 

What am I missing here? I’ve heard of people that have had success with this adapter and a M1 Mac mini, so perhaps it’s related to the iMac specifically?

 

Any help would be much appreciated!

 
  • Liked by
Reply
5 on 27-08-2021

You are getting 1280×800? Is it 1280×800 HiDPI (smooth text) or 1280×800 scaled up to 2560×1600 (blocky, pixelated)?

See if the 2560×1600 option exists in SwitchResX?

on 27-08-2021

I’m only getting 1280×800 scaled to 2560×1600. 

The 2560×1600 option does not exist in SwitchResX

I’ve also tried adding a custom resolution into SwitchResX, but says “not activated – invalid?”

on 27-08-2021

 

on 29-08-2021

M1 Macs don’t give any useful diagnostic info so I can’t say what’s going on. On an Intel Mac, I would use the AGDCDiagnose command to get some info.

M1 Macs don’t use display overrides so we can’t do workarounds for some problems.

The CAC-1510 requires four lanes of HBR to support 2560×1600 mode. The M1 Mac should be capable of that.

Maybe try connecting the adapter to a Thunderbolt 3 dock. The HP Thunderbolt Dock G2 has a USB-C port that is part of a MST Hub which might be useful because it can convert two lanes HBR2 or HBR3 to four lanes of HBR (in case some lanes aren’t working).

I you want to try adding a custom resolution, the timings for the supported modes are:

[email protected] 49.306kHz 71.00MHz h(48 32 80 +) v(3 6 14 -)
[email protected] 98.529kHz 268.00MHz h(48 32 80 +) v(3 6 37 -)

but M1 Macs don’t use display overrides so it probably won’t help to create a custom timing.

What does the script at https://gist.github.com/joevt/e862b0088ef58b9144877d01401bcee8 show?

 

5 days ago

Did you try clicking on Selected resolutions while holding the ALT key pressed? That worked for me…

2 days ago

Did you try clicking on Selected resolutions while holding the ALT key pressed? That worked for me…

From theorix

Yes, that’s the way to do it

Show more replies
  • Liked by
Reply
Cancel