Macbook Pro 13″ 2015 (Intel) + Philips PUS7600 = no 60Hz

Updated on 28-02-2017 in Adapters and Cables
8 on 31-05-2016

Hi, i tried everything. But i’ve no success with 4k/60Hz on OSX. Here is my configuration:

  • Macbook Pro 13″ (Spring 2015, Intel GPU)  with Thunderbolt/DisplayPort 1.2 and El Capitan
  • CAC-1170 Rev: A2-00, FW: V7.23
  • Philips 48PUS7600 (latest Update: 5.38.68) with UHD 4:4:4/4:2:2 or UHD 4:2:0
  • Certified 18Gbps HDMI Cable (Oehlbach Black Magic 170)
  • SwitchResX with Custom 3840×2160 / 60Hz (CVT-RB or CVT-RB v2)

Had anyone success with a Macbook 13″ Intel Configuration?

  • Liked by
0 on 10-06-2016
  • Liked by
2 on 10-06-2016

I tried this already. I also made a new User for SwichResX, but without any success. 

Maybe it’s the TV, here you’ll find the EDID Export from SwitchResX for the PUS7600:

on 11-06-2016

I also bought the recommend CAC-1310 4k60Hz HDMI Cable, but it’s the same… no 60Hz.

In the EDID from the TV there is a  “Maximum bandwidth range” (=Pixelclock?) with 300 MHz ?!?

This seems to be not enough for 4k60Hz…?, or is this information only for the FullHD Mode? There ist only one reference to 4k60Hz:

Data Block Collection #1 - Type 2
	Video Type: standard CEA Timings
#19: 3840 x 2160p @ 60Hz - 16:9 (97)

But without any Pixelclock reference.

Do i have to change the EDID somehow?

on 13-06-2016

i will send over the pixels clocks supported by the adapter by email for your reference

Show more replies
  • Liked by
1 on 15-06-2016

I got it!  Smooth 60hz with my Macbook and the Philips TV! 😀

Here’s what i done:

  • reset all SwitchResX custom Settings
  • remove SwitchResX  from my OSX
  • create a new User in OSX
  • change my locale/language to english
  • installed SwitchResX again for the new User
    SIP needs to be disabled ->
  • connect the TV with CAC-1170 
  • select 4k30hz (default, not custom – important!)
  • Create a Custom Resolution without  simplified settings and CVT-RB
    – only this way SwitchResX uses the same TV specific settings like in the 4k30Hz Mode
    – change now only the Vertical Scan rate to 60.000
  • close the window and save
  • on your TV check that made all the TV specific settings (Computer Mode, UHD 4:4:4)
  • turn off your TV (without i had 60hz which felt like 30hz – really strange…)
  • remove CAC-1170 from the Macbook
  • Reboot your Mac!  
  • turn TV on again
  • connect the CAC-1170 (if i leave it connected i got just a blue screen)
  • select 4k60Hz in the settings and now it should work!
  • = 60Hz!  (at least for me)
  • and the best of all… it works also with the cheapest (1€ from eBay ) HDMI 1.3 Cable (2 Meters)! 
    (i spend at least 100€ for the  HDMI 2.0 Cables like from Oehlbach, the recommend Club3D HDMI 2.0, Amazon Basics and much more…. all unnecessary…)

I’m not sure if everything is necessary, but only this way i got it working. And i tried every tip and hint from the forum and spend days to come to my final solution… Maybe it was just a corrupted SwitchResX, but who knows…

And maybe someone finds a solution how i can avoid the Blue Screen on the TV when i reboot the mac? Until now i need to reconnect the CAC-1170 everytime. On a Macbook its okay, but annoying.


And @MST1407 – thanks for the Mail. It cleared some things  up.

on 16-06-2016

No thanks, happy you got it working  🙂

Show more replies
  • Liked by
1 on 23-02-2017

I read MacBook pro late 2013 15″
Is it a i7 2.0 8gb
Will it work with the Adapter?

on 28-02-2017

Hi Superkatsu,

Yes that should work

Show more replies
  • Liked by