Need Help! MST Hub Displayport 1.2 Dual Monitor not working

Updated on 17-10-2016 in MST Hub
2 on 13-10-2016

Dear All,

Recently I bought Multi Stream Transport (MST) Hub DisplayPort™ 1.2 Dual Monitor. I was planning to set triple (3) monitors with the following specification:


  • Dell Precision T5810
  • Intel Xeon 2.8 Ghz
  • RAM 16 GB
  • Windows 7 Pro – 64 Bit
  • GPU: NVIDIA Quadro K620 with input: 1 DP 1.2 and 1 DVI-I


  • 1st Monitor: Eizo 27″ Flexscan EV2750 (Res: 2560 x 1440)
  • 2nd Monitor: DELL 1703 FP (Res: 1280×1024)
  • 3rd Monitor: DELL E228WFP (Res: 1680×1050)

I connected the 1st Monitor to directly to the GPU using DVI-I and 2nd and 3rd Monitors (via adapter DVI-to DP) to the 3d Club MST Hub. 2 monitors which are connected to the 3d Club MST Hub can’t be detected and only 1 monitor can only be detected which is Eizo 27″.

Then I changed the configuration, 2nd Monitor I connected to the GPU via DVI-I and 1st and 3rd Monitor I connected to the Hub using adapter DVI-I to Displayport. All of the 3 monitors was able recognized by the Windows and NVIDIA software. But 1 monitor connected to the Hub which is DELL showed only blank screen.

Then I changed again the configuration, I kept the EIizo monitor connected to the hub (working well), and I changed one of the DELL Monitors connected to the GPU and connected to the Hub. Again, all 3 monitors are recognized by the Windows and GPU. But only 1 DELL Monitor which is connected to the Hub showed blank screen (Black).

If you have any experience or idea about this problem please let me know. Thank you.

  • Liked by
1 on 13-10-2016

Please need help… I have tested just used 2 DELL Monitors as above and connected to the MST Hub using DVI-I to DP adapter, the screens are still black…

on 17-10-2016

Sounds like a Dell Screen issue to me …


Dell Monitors sometimes need to have MST Feature enabled manually …

Please refer to your Dell monitor’s owner manual for instruction for enabling DisplayPort 1.2 Multi-Stream Transport (MST) capabilities on your Dell monitor.

By default the Dell monitors are not enabled with this feature.

In the monitor’s on screen menu (OSD), navigate to “Other Settings”

Change the setting for “DisplayPort 1.2” to Enable

Confirm the selection

You may need to reconnect the DisplayPort cable after making this change.

Show more replies
  • Liked by