No display with AsRock FM2A68M-HD+ mobo

Updated on 13-01-2016 in R9 270 Series
7 on 04-01-2016

Dear all,

I just purchased the following parts as a setup.
AMD Athlon X4 860K Boxed
ASRock FM2A68M-HD+
Crucial Ballistix BLS2CP4G3D1609DS1S00CEU
Club 3D Radeon R9 270 royalQueen
Crucial BX100 250GB
Cooler Master N200 Closed
be quiet! System Power 7 350W
Samsung SD590

When booting, I get no screen/display (it’s just black) when using the Radeon R9 270 with both the dvi and hdmi connector. When I use an old card (Radeon HD 4870), the bios gets loaded just fine. Also, when trying the Radeon R9 270 in a different pc, all is well (an Intel setup however).

I already updated the bios to the latest version (1.90) and tried to build up the pc piece by piece to see what may cause this issue.

Since the CPU is not supporting any graphics, I cannot try the onboard connectors. So the minimal setup I use is mobo+cpu+1 dimm+gpu.

Any idea what is causing this issue or help on solving it?
Thanks in advance!

Best regards,


  • Liked by
1 on 06-01-2016

Good day McScan,

Please try updating the Bios of the Mainboard.

on 06-01-2016

Hi MST1407,

You probably missed it in my msg above, but I stated: “I already updated the bios to the latest version (1.90) and tried to build up the pc piece by piece to see what may cause this issue.” 

Version 1.90 is the latest. With the AsRock bios you can even connect to the internet to download it, which I did – two days ago.

Any other suggestions?

Show more replies
  • Liked by
0 on 06-01-2016

Hi MacSan,
Can you do the following?
If you have already Windows installed in your system, please insert the old card and once you boot into windows, go to device manager and uninstall the graphics driver.
Once you do this, shutdown the system and unplug the power, press the power on button for a few seconds to drain the power.
Install now the new card and see if everything is working. Also good to reset the Samsung SD590 screen.

  • Liked by
3 on 06-01-2016

Hi Paul,

Thanks for this! I haven’t installed anything concerning OS’s, while this issue is still pending. But I was pondering about a route you now suggest. So I will be trying this.

I just resetted the screen, to no avail (at the moment).

I’ll keep you updated.

BR, MacSan

on 06-01-2016

Hi Paul,

I have just tried the above actions. It didn’t result in getting any display from the R9 270 unfortunately. 

Anything else I can try?


on 09-01-2016

Did you check your system power? The 350W power might not be sufficient for your system. What is the power on the Intel PC?

on 13-01-2016

With that psu you  have 18 Amps on your 12 Volt line , i think thats not enough

Show more replies
  • Liked by