Please try this, it worked for me …somehow (im back to 4k60hz)

Updated on 12-03-2017 in Adapters and Cables
0 on 12-03-2017

Ok so for the longest time i’ve been having the issue like many have where i could only get 4k30hz to work , it was annoying as hell considering when i first got the cable it worked flawlessly. so last night i gave it one more shot ..and this is what i did and it worked .

If you have two monitors attached , right click the desktop and click display settings, then from there where it says “multiple displays” click extend these displays” you’ll have both monitors on , how you should be able to change the display to 4k and then when you click display adapter properties it should have 60hz as an option, click ok and you should be good to go. if it doesn’t work, im not sure what else to do.

NOTE: after you’ve set your resolution, you can go back to a single monitor and it should stick. mines been working fine now even with multiple reboots.

  • Liked by
  • MST1407