Purple Screen with Netflix Windows 10 App (wtih HEVC Extensions installed)

Updated on 18-01-2022 in Adapters and Cables
6 on 18-01-2022

Hi there,

I have been using the CAC-1070 for years without issue. I recently installed the HEVC Extensions from the Microsoft Store so the Netflix app would support 4K playback. Now it shows the purple (HDCP unauthorised) screen when opening Netflix, and no amount of unplugging/plugging in the HDMI cable will reset it. As a workaround, I uninstalled HEVC Extensions and Netflix works only at max 1920×1080.

Would a firmware update resolve the issue, or would I need to buy one of the newer adapters to support the latest HDCP pass-through for Windows 10 apps? i.e. the CAC-2070? I don’t mind purchasing a newer adapter if need be.

tl;dr – I’m running my graphics settings at 3840×2160 @ 60Hz RGB 8-bit. I’m using Windows 10 Netflix app to watch content. It only runs at max 1920×1080 without HEVC Extensions installed. With HEVC Extensions installed, Netflix only shows purple screen of death. Uninstalling resolves it, but again only plays max res 1920×1080.

System specs:

· Self-built PC (Asus TUF X299 Mark 2 / Core i9 9900X / 32GB / Nvidia RTX-2060 Founders Edition)
· DisplayPort 1.4a (RTX-2060) –> CAC-1070 Adapter –> HDMI 1.4a (TV input)
· TV: Samsung UE40HU6900FXXU (HDMI 1.4a max)
· Windows 10 Pro 2004 (up-to-date)
· HEVC Extensions from the Microsoft Store to allow 4K playback via Windows 10 apps

Thanks, Jim.

  • Liked by
3 on 18-01-2022

Both CAC-1070 & CAC-2070 both support the same HDCP 1.3 and HDCP 2.2 so doubt changing this would solve the troubles.

You say that the input of the Samsung is HDMI 1.4 Max? Have you tried 30Hz? That is the max HDMI 1.4 supports at 4K.

Have a look at the resolution guide:


Hope this helps a bit !

on 18-01-2022

Thanks Baak. I didn’t think about trying 30Hz. Suppose I could try reducing to 4:2:2 colour depth and see if that works.

Okay, I’ve just tried every possible combination of 3840×2160 @

Refresh: 23Hz, 24Hz, 25Hz, 29Hz, 30Hz, 50Hz, 59Hz, 60Hz
Colour: RGB / YCbCr 4:2:2
Dynamic Range: Full / Limited
Bit depth: 8-bit / 10-bit / 12-bit

No combination works. Hmm… My TV was manufactured in 2014 (and designed before then) so I’m guessing it only supports HDCP 2.0 IIA, 2.1 IIA and 2.2 IIA, but not the newer version of “HDCP 2.2 for HDMI”. I guess it’s time for a TV upgrade!

Thanks for your help, Baak. Greatly appreciated.

on 18-01-2022

Happy to assist,

If you upgrade a new TV look for a 4K120Hz display. Add a CAC-1085 + CAC-1372 for your RTX2060. Only way for you to get 4K120Hz, it’s worth, trust me 😉

Have you tried a direct cable from RTX2060 to the Samsung? Try that too.

on 18-01-2022

Thanks. I’ll keep that in consideration when I do upgrade in the future. Thankfully it works now when going through the MHL HDMI port. 🙂

I did try the direct HDMI from the RTX-2060 to the TV, but this maxxes out at 30Hz for some reason, which is why I stuck with the CAC-1070 adapter.

Show more replies
  • Liked by
1 on 18-01-2022

Good news! I figured out that I have an “MHL” HDMI input on the back of the TV that does support the newer “HDCP 2.2 for HDMI” protocol (not the older HDCP 2.0 IIA, 2.1 IIA or 2.2 IIA protocols). Plugging into the MHL HDMI port works perfectly at 3840×2160 @ 60Hz RGB 8-bit.

Just in case anyone else has the same issue I had, ^THIS^ works.

on 18-01-2022


Show more replies
  • Liked by