Screen flashing solid colors with CAC-1070 DisplayPort-HDMI adapter

Updated on 09-01-2017 in Adapters and Cables
4 on 16-12-2016

I tried submitting this to tech support, and the form just cleared itself when I clicked the submit button. So, part of my question is how to successfully submit a question to tech support.

Product: CAC-1070 DisplayPort-HDMI adapter
Purchase location and date: 11/17/2016
Graphics: Intel U6300 HD Graphics 520
Graphics driver: (10/24/2016)
OS: Windows 10 64-bit
Monitor: 4k Samsung UN49KU6500FXZA

Problem: As of yesterday, the screen flashes between solid colors (green, orange, cyan, black, white, blue). Before that, it worked great.

What works:

    • A different monitor (1080p) plugged in to this adapter and computer
    • This monitor plugged directly in to HDMI on this computer (at 30 Hz)
    • This whole hardware combination a couple of days ago

What I tried that did not work:

    • Different refresh settings (30 Hz), different resolution (1080p)
    • Powering everything off for an hour
    • The other DisplayPort connector on the computer
    • Plugging a different monitor in to the adapter (the other monitor works, but when I had this same problem a couple of weeks ago, plugging in a different monitor seemed to fix the 4k monitor when I went back to it)

Any ideas of what to try next would be appreciated.


  • Liked by
0 on 16-12-2016

Another bit of information: it stopped working after my password expired and I got locked out of windows, so our company IT support had to reset it. Maybe Windows reverted to an older driver or something?

  • Liked by
0 on 16-12-2016

Well, I answered the first part of my question. Someone from tech support responded, so when it looks like submitting a ticket didn’t do anything, it actually did! So far, they have not been able to help me, so I would still appreciate suggestions.

  • Liked by
1 on 05-01-2017

The tech support person provided me with a firmware update utility, which fixed the problem.

Apparently the adapter was bricked somehow by the custom resolution settings I was trying in attempt to get 4k 60 Hz 4:4:4 working with Intel HD Graphics 520. The problem wasn’t with the old firmware, because when I tried the custom resolution settings with the new firmware, it got bricked again, so I had to load the firmware again.

on 09-01-2017

Hi Chris,
Indeed we did receive your message  on the 16th of December. So that went thru.

And good to hear it is working for you.

Thanks for the feedback.

Show more replies
  • Liked by