Surface Pro 4 and Asus PB287

Updated on 24-07-2016 in Adapters and Cables
10 on 13-07-2016

I just bought Surface Pro 4  with dock. Monitor is Asus PB287.
I bought and tried several cables in order to get [email protected], (org. MS, Apple, mini-DP to DP, and Club 3d cac-1170.) Unfortunately, all of these cables stay at 29Hz, and SP4 does not show any 60Hz option at 4K, both for direct to SP4 as to the dock ports.

Then I created custom resolutions with Intel HD Graphics Control Panel (using cac1170), but as soon as I select the 59 or 60 Hz for the monitor, it stops telling me there is no signal. So, after spending over 100 euros in useless cables, and hours looking & reading & trying, still stuck with 29 Hz…
Anybody smarter than me?

 
  • Liked by
Reply
0 on 13-07-2016

Did you try it without the dock, just connect the CAC-1170 to the SP4 and HDMI Cable to the screen ?

  • Liked by
Reply
Cancel
0 on 13-07-2016

Yes, I took the dock out of SP4, so the only device connected was the cac1170 via mini-DP. 
when selecting 59 or 60Hz in the Monitor Properties, PB 287Q screen turns blue stating no input in HDMI-1. As soon as I select back to 30Hz, screen turns on again.

  • Liked by
Reply
Cancel
0 on 14-07-2016

Nobody else having this issue with Surface Pro 4?

  • Liked by
Reply
Cancel
0 on 15-07-2016

Did you try to make a Custom Resolution with Timing Standard at CVT-Reduced Blanking ?

Action:

Manually downloaded and installed (don’t let that auto-updater from Intel do that) Intel Graphics Driver pack 15.40.25.4463, which contains DisplayAudio Driver 6.16.00.3197 plus Graphics driver 20.19.15.4463.

Open Intel Graphics Control Panel, Chose “Custom Resolutions” (left bottom option)

It will asks you if you wish to continue; YES

Standard the “Basic” setting is shown, click on “Advanced” , Fill in; Width 3840 ; Height 2160 ; Refresh Rate 60 ; Timing Standard CVT-RB ; and click on “ADD”on the right bottom of the window.

Now this resolution I added to the system and can be chosen.

Go back to “General Settings”(left top) , it will show the basic options and here you can now choose the 3840×2160 resolution and 60Hz.

When you have such a blue screen, can you please try to only take power off the Screen for about 10 seconds (just take the power plug out) and re-connect it. To see if that makes a difference.

  • Liked by
Reply
Cancel
3 on 16-07-2016

Hello MST1407..
this is exactly how I did this already. These settings are in the basic settings group, not in the ‘ Advanced’ group. Only difference is I had the 20.19.15.4474 graphics driver. I do not see any display audio driver installed, though.
Pulling the power cord out and back in brought up the blue screen again and after several seconds the screen turns itself off as no signal detected on HDMI 1.
I have no more ideas what to do in order to solve this. The 30Hz is not very pleasant to work with.
Thank you,

on 17-07-2016

What Brand/Type HDMI Cable are you using ?

on 17-07-2016

I used 4 different ones, but al not getting 60Hz.
The one in the picture also produced bad sound quality, but again, I am not sure if special audiodrivers for the screen are required or available.

on 18-07-2016

Also tried this mini-Displayport to Displayport

Show more replies
  • Liked by
Reply
Cancel
1 on 18-07-2016

MST1407.

I GOT IT!  it turned out that with the added customized settings, it did not work with the active adapter, and a HDMI cable, but the setting do work with the mini-displayport to displayport. That is the trick…. The cheapest cable did the best job!
Thank you for your time and help
Eira

on 24-07-2016

glad you got it to work 🙂

Show more replies
  • Liked by
Reply
Cancel