Windows 10 problems sasmung tv resolution. DisplayPort™ 1.2 to HDMI™ 2.0 4K60Hz UHD Active

Updated on 23-07-2016 in Adapters and Cables
6 on 12-05-2016


I have a Samsung UN40JU7100 and I used to use windows 8.1 on my pc on it via R9 390x GPU and 4k adapter, everything worked great.

My issue here is that when I upgraded to windows 10 my samsung tv does not acknowledge the resolution size which should be 3840 by 2160p @60hz. It just shows it at 4096 by 2160p @60hz.  I tried changing resolutions on my pc but all resolutions acknowledge 4096 by 2160p @ 60hz on my tv but im pretty sure that it is changing resolution according to pc settings but just saying its at 4096 by 2160 on the tv. Is there a firmware to fix this issue?

  • Liked by
4 on 13-05-2016

Hi Rick, thank you for joining our forum. 

Did you upgrade to Win 10 or performed a clean install? If you upgraded, please do a clean install (many of the issues reported are from users who upgraded to Win10 from 7 or 8.1). 

If that doesn’t solve the issue it’s best to create a custom resolution by following these steps: 

Make a custom resolution in the Crimson driver.
Open the Crimson driver, click on “screen”, then on “additional settings” on the top.
A new windows opens called “Radeon additional settings”.
On the left at “My Digital Flat Panels” you can chose the option “custom resolutions”, click on “new”
and you can do a resolution setting manually …
Horizontal: 3840
Vertical: 2160
Refresh rate 60 Hz
Interlaced/Progressive: Progressive
Timing Standard: CVT-Reduced Blanking

on 17-05-2016

Its not working correctly. I clean installed windows 10 64bit. The latest amd gpu drivers are not working correctly on my tv. What else can i do?

on 17-05-2016

Same issue with Samsung UE50HU6900 (2014) and SEK-3500u (2015). Both have HDMI 2.0 ports and UHD color mode is Enabled. My GPU is Asus Strix R9 285.

With latest Crimson Drivers and clean W10 install I’ve managed to get 2160p@60Hz YCbCr 4:4:4 (8 bit) ONCE. It returned to 30Hz next reboot. DisplayPort handshake failure, or something.

Troubleshooted this issue before with the great Club3D support for about 3 weeks. Firmware was updated and every possible combination was tried by me – including custom EDID-overrides! After a complete rebuild/upgrade my PC to Skylake i7 the issue still remains the same. It’s not a Windows 10 or HDMI cable issue, honestly, with Microsoft basic display driver 2160p@60Hz 4:4:4 works right away.

This adapter does have issues. Do not spend too much time with troubleshooting like I did.

on 02-06-2016

Did you check if the the TV “Set Edit Device Type” is set at “PC ” …

on 23-07-2016
Did you check if the the TV “Set Edit Device Type” is set at “PC ” …From MST1407

Please see my long post in this thread for info on how to partially solve this issue so that you may help others with similar issues.

Show more replies
  • Liked by
0 on 23-07-2016

I had a similar issue. The problem was rectified by displaying the desktop on the Samsung display, ensure the input is in the HDMI/DVI port (typically HDMI1), ensuring that this port is labeled as a PC input (press “Inputs” button on remote, highlight the input, pres down, change input type, and set to PC). Next go to the control panel under “Display>Advanced Settings” and verify that the resolution for the 4k TV is set to the correct 3840×2160 resolution (many times control panel will incorrectly have 4096×2160 the “Recommended” resoution for a 4k TV, ignore this and set to 3840×2160).

From there you need to press the menu button on the remote and navigate to the “UHD Color” setting on your TV on the input the computer is plugged into.  This setting needs to be cycled off, then back on for that input. Doing this requires the TV to restart each time.

Once you cycle the “UHD Color” option back on for that input the display should now show the correct resolution on the TV’s info button display (3840×2160 / 60p). The display should also now correctly be displaying full 4:4:4 chroma subsampling as the CAC-1070 and CAC-1170 are meant to be able to do.

Keep in mind, after cycling the the UHD Color option off then back on, the display may still not be detecting the resolution correctly (and will be putting out 4:2:2 chroma subsampling). If this is the case you will need to cycle the UHD Color option off and onn again, possibly several times until you get the desired result.

Also important to note that once you turn the TV off then go back and turn it on later the TV will have reverted to it’s previous state and you will have to jump through the “UHD Color” of-on cycling hoop again to get back to your desired result.

I am unaware of any way to make the computer/adapter/display remember the correct state after the TV is turned off.

Hope this helps, best of luck.

  • Liked by