Club 3D & Intel: Lets sort out issues with Intel Graphics and CAC-1070 /1170!

Updated on 20-11-2017 in Adapters and Cables
20 on 26-02-2016

Since many of us are having issues with getting CAC-1070 and/or 1170 to work with our Intel Graphics setup, I felt it was necessary to break from the feedback thread and consolidate our efforts here.

I’ve entered a new thread in the Intel forums to bring the issue to the forefront and consolidate our efforts on their side as well. Please provide both Intel and Club 3D with feedback and so we can determine what exactly needs to be done to settle any outstanding issues: firmware, BIOS, drivers, EDID, etc..

This is also an effort to bring communication between Intel and Club 3D to the community so we can better assist both parties in a more efficient manner. Thanks.

  • Liked by
0 on 29-02-2016

Hi Onizuka, thank you for initiating this contact. Also on behalf of many users of (m)DP enabled Intel based notebooks, NUC’s etc. Our technical support team is gladly willing to work with Intel to see if there is a way to get 4K 60Hz working with their 3rd and 4th Generation Graphics.

  • Liked by
2 on 02-03-2016

Hi there,

I’m in the same boat as many others, so here’s my hardware combination:

Sony X930C 4K TV (updated firmware)
Intel NUC 5i5RYK (updated BIOS & all drivers)
Monster UltraHD Black Platinum 4K HDMI cable (rated at 27 Gbps)

Since buying the Monster HDMI cable, I now have the option in Windows 10 to select 4K resolution at 60Hz refresh rate, so the cable was obviously a bottleneck prior to this.  However when I select it and the TV tries to display it, the screen goes black for a few seconds and then reverts back to the previously selected resolution.  The highest it will go successfully is 4K at 30Hz.

I have now sent 2 emails asking for the firmware update, but Marcel seems reluctant to send it … I’m not sure why.  He has responded with the standard troubleshooting steps, which I have followed with no success.  One glaring issue with the standard troubleshooting as I see it, is the need to change the colour depth to 8 bit.  Unfortunately, Windows only supports 32 bit depth, which has been the case since Windows 8 … so as far as I can tell, I don’t have the ability to change the colour depth to 8 bit as suggested.

I would love a solution … anybody … Bueller?

on 04-03-2016

Hi Jerry,
Sorry for the delay, email replied and firmware link send to your email …

on 05-03-2016

Thanks I tried the firmware update but the app doesn’t work on Broadwell NUCs. So it seems I have no way to check or update the firmware at this point. Very disappointing I must say.

Show more replies
  • Liked by
0 on 04-03-2016

Hi Team Club 3D,

My guess is Intel is reluctant to join the conversation on this thread. Possible you guys throw your hat in their thread to officially cross-pollinate?


  • Liked by
2 on 06-03-2016

Please see here how I got it working:

on 24-09-2016

It worked, but guess what: HDMI audio gets corrupted when running at 60Hz. Everything sounds like fart (sounds like playing digital bits through analog speaker without a DAC). Can anybody verify if it’s an Intel problem or it’s the problem of CAC-1070?

on 18-10-2016
It worked, but guess what: HDMI audio gets corrupted when running at 60Hz. Everything sounds like fart (sounds like playing digital bits through analog speaker without a DAC). Can anybody verify if it’s an Intel problem or it’s the problem of CAC-1070?From catbert

 I have the same problem but I don’t know if that’s due to the adapter. In my case I cannot get the 4k@60Hz going but I still get the digital fart from the speakers. To remedy this, if it’s music I listen to, I pause and play until it disappears. The distortion happens sometimes when I change audio sources, from TV to internal speakers to headphones and sometimes it appears spontaneously.

Show more replies
  • Liked by
1 on 09-04-2016

I was able to get the CAC-1170 to put out 3840×2160 @ 60Hz from Intel HD Graphics 4600 using Liam’s post. Using the latest Intel graphics driver (, doesn’t need to be the beta) you make a custom resolution for 3840×2160@60 Hz and use the CVT-RB timing standard instead of GTF. Then go back to the General Settings and 60p should be an option under Refresh Rate. Color stays at 32 bit. Tested with both regular use and a bunch of videos and everything is working fine so far (Big Buck Bunny 3840×2160 60fps was buttery smooth: Big Buck Bunny 3D – Download). HD Graphics 4600 only has H.264 and HEVC 8-bit hardware acceleration (no VP9 or HEVC 10-bit) so 2160p60 videos on youtube and 2160p 60fps 10-bit x265 videos were stuttering pretty badly for me (with CPU @ 100%).

It’s annoying that Intel Graphics uses the old GTF timing standard by default instead of the newer CVT/CVT-RB standard. RoyalKing, maybe you can convince your Intel contact to make their software at least pick the timing standard based on the EDID from the display rather than requiring a custom resolution to use the newer standard.

on 09-04-2016

Glad to hear you got it working too! Also, good to know about the x265 videos. I’ve been doing a lot of 4k screen capture recently using Bandicam and that uses my discreet Nvidia GPU, albeit I am creating 4k x264 MP4 files. I can use the Intel QuickSync too but my tests found the NVidia to be far more suitable for that kind of workload.

Show more replies
  • Liked by
0 on 26-09-2016

I have a Sony X85C TV (latest firmware v. 3.473) enabled 4k 60hz option on it,
and ASUS laptop with intel broadwell and iris 5500 graphic. and mini dp 1.2 connector.

Im now trying to get 4k 60hz from my asus laptop with the club 3d dp 1.2 to hdmi 2.0 adapter but it does not work.

I have the latest intel graphic driver from intel update tool.
The Club 3d firmware (ps176b0_0x07.0x00.0x1e_encryt_bank12 )
and running windows 10. 
Change to custom resolution 4k @ 60hz and CVT-RB.
When i change the resolution to 4k and 60hz the tv flicker and tries to change but fail and then go back to 1080p 60hz.

I have also tried the a other computer with nvidia 960 gtx with hdmi 2.0 at 4k @ 60hz and it worked flawless. i use the same cable and everything to the tv.

  • Liked by
8 on 27-09-2016

Hi All,

I would like to chime in on my labours with the adapter and setup.

Rev: A2-00
Fw: V7.23
TV: Philips 49PUS6501/12
Laptop: Lenovo L440 single GPU Intel HD4600
OS: Arch Linux 4.7.4-1-ARCH
The GPU is more than capable of pushing 4k@60Hz. I had a 43″ Philips BDM4350C and it worked flawlessly through the DisplayPort.
For the present TV, out-of-the-box I would get only 30Hz@4k but for some reason overhead is added as if post processing is being activated. The mouse feels sluggish and you can feel a lag even for key presses. A reaction test between different resolutions revealed a difference of ~120ms between 1080p@30Hz and 4k@30Hz:
Average of 5 tries:
1080p60Hz: 268ms
1080p30Hz: 324ms
2160p30Hz: 447ms
I checked and double checked the settings in the TV to make sure they all are off and the TV is in PC mode. (Game in Philips’ case)
I don’t know how many people use Linux around these parts but in my case my search results for a similar setup led me to this post
So i tried to play with the modelines for both the CVT and GTF timings.
These were my modelines:

# 3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz
Modeline "3840x2160_60.00" 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync
# 3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
Modeline "3840x2160R" 533.00 3840 3888 3920 4000 2160 2163 2168 2222 +hsync -vsync
# 3840x2160 29.98 Hz (CVT) hsync: 65.96 kHz; pclk: 338.75 MHz
Modeline "3840x2160_30.00" 338.75 3840 4080 4488 5136 2160 2163 2168 2200 -hsync +vsync
# 3840x2160 @ 60.00 Hz (GTF) hsync: 134.10 kHz; pclk: 712.34 MHz
Modeline "3840x2160_60.00" 712.34 3840 4152 4576 5312 2160 2161 2164 2235 -HSync +Vsync
# 3840x2160 @ 30.00 Hz (GTF) hsync: 65.91 kHz; pclk: 339.57 MHz
Modeline "3840x2160_30.00" 339.57 3840 4080 4496 5152 2160 2161 2164 2197 -HSync +Vsync

Of interest were the CVT-60Hz and GTF-60Hz. I would get a black screen and one line visible at the top. I could see the cursor moving in the form of a dot, but nothing else happened, not even fallback to 1080p
Here’s the dmesg.
Here’s the Xorg log.
I already sent an email to Club3d support explaining my situation but not as thoroughly as this post.
Any help would be greatly appreciated. The main reason for having this purchase was to double down as a computer monitor. If any more information is necessary let me know.

on 18-10-2016

I tried buying the CAC-1310 cable to rule out the cable factor, no success!
Another experiment was with getting a CAC-1070 adapter and using an already available miniDP to DP adapter to connect to the CAC-1070 and then the CAC-1070 to the CAC-1310 cable that goes into the TV.
So the tries used so far are:
Lenovo L440 <=> CAC-1170 <=> CAC-1310 <=> Philips 49PUS6501/12
Lenovo L440 <=> miniDP-to-DP1.2 <=> CAC-1070 <=> CAC-1310 <=> Philips 49PUS6501/12
Both unsuccessful!

CAC-1070 Specs:
Rev. A3-00
FW. V7.26

CAC-1170 Specs:
Rev. A2-00
FW. V7.23

on 20-10-2016

Which CPU you have inside ?

on 20-10-2016

Intel® Core™ i5-4200M @ 2.50GHz

on 20-10-2016

Please do this:
Uninstall current graphics driver software. 
Manually downloaded and installed (don’t let that auto-updater from Intel do that) Intel Graphics Driver pack, which contains Display Audio Driver plus Graphics driver Open Intel Graphics Control Panel, Chose “Custom Resolutions” (left bottom option) It will asks you if you wish to continue; YES
Standard the “Basic” setting is shown, click on “Advanced” , Fill in; Width 3840 ; Height 2160 ; Refresh Rate 60 ; Timing Standard CVT-RB ; and click on “ADD” on the right bottom of the window.
Now this resolution I added to the system and can be chosen. Go back to “General Settings”(left top) , it will show the basic options and here you can now choose the 3840×2160 resolution and 60Hz.

on 20-10-2016

by the way i would just use the CAC-1170 instead of CAC-1070 + MiniDP-to-DP adapter

on 20-10-2016

Unfortunately in my case I run a Linux distribution (Arch Linux) and those drivers apply only to Windows/MacOS. If you happen to have any tips for the Linux platform I’m more than happy to try them out.

Yes the CAC-1170 is the simpler solution but the CAC-1070 is more future proof due to my intent to switch to a dedicated GPU down the road + might as well put the DP-to-miniDP adapter to good use.

Thank you for your help

on 19-11-2017

after a year of neglect, I decided to revisit the issue. As per this article, it seemed that the problem was with the default parameters of my desktop environment (ie GNOME) After removing the monitors.xml file and adding the custom resolutions to the xorg config file I have a working 4k@60Hz session albeit running on X11 instead of Wayland. The issues with input lag (ie mouse reaction time) have been resolved.

on 20-11-2017

Good to hear happy you got it going 🙂
And thanks for the feedback.

Show more replies
  • Liked by