DP to HDMI2.0 adapter – 4k on 60p not working since AMD hotfix

Updated on 15-12-2016 in Adapters and Cables
36 on 22-09-2016

Hi guys, I use the Club3D DP to HDMI 2.0 adapter to connect my PC (R9 390) with my Samsung TV.
Worked fine until I downloaded the AMD hotfix 16.9.1 – now I can only run 30p on 4k resolution.
Also on my display adapter only the 30hz option is available via dropdown menu – I actually think it is a driver problem, but someone on reddit told me that I will get a new firmware for my adapter if I post here.
I thought it is worth a try – where can I find the firmware downloads for my adapter?
Thanks in advance!

 
  • Liked by
Reply
0 on 28-09-2016

I have the same problem with my Crossfire Fury’s.  I downloaded the Hotfix drivers for Forza Horizons 3 and noticed that I could only set the refresh rate in game to 30Hz.  I downloaded Custom Resolution Utility (CRU) to manually set the refresh rate to 60Hz and just got a black screen.

  • Liked by
Reply
Cancel
2 on 28-09-2016

Rolled back drivers and 60Hz works again.

on 29-09-2016

Perhaps first try to clean the driver and all related Graphics Software first before installing new driver. So don’t use update feature. Also please do un-install in Safe Mode so the registry can be cleaned or use program like DDU (DisplayDriver Uninstaller). http://www.wagnardmobile.com/?q=node/103

I mean i like the roll-back solution best, but in case you would need to update drivers … that is worth a try

on 29-09-2016

I always use DDU. Forza Horizons 3 crashes on the “Optimizing Settings for your PC” screen at 74% every time on the old drivers so rolling back isn’t a great solution.

Show more replies
  • Liked by
Reply
Cancel
1 on 28-09-2016

I have the same problem since the amd update can only choose 1080p now

on 29-09-2016

email send from [email protected]

Show more replies
  • Liked by
Reply
Cancel
0 on 29-09-2016

email send from [email protected]

  • Liked by
Reply
Cancel
4 on 01-10-2016

Uninstalled Afterburner, used DDU in safe mode to uninstall drivers. Installed 16.9.2 drivers again and can still only choose from 23, 24, 25, 29 and 30Hz at any resolution above 1920×1080.

on 02-10-2016

Sorry mister fancy pants, i know you dont really want to hear this, but i would advise you to keep unsing 16.9.1 until amd has a fix for the many issues 19.6.2 seem to cause

on 04-10-2016

BY the way did you try it without the crossfire enabled ?

on 04-10-2016

I did not but would that make a difference on the desktop?

on 05-10-2016

just checking what influence that would have

Show more replies
  • Liked by
Reply
Cancel
2 on 05-10-2016

Hi All,

Did anyone already try use 3rd party program like CRU to overwrite the settings of the 16.9.2 driver ?

http://www.monitortests.com/forum/thread-custom-resolution-utility-cru

on 05-10-2016

Yes, I did and just got a black screen.

on 07-10-2016

please load a system restore point from before the problems started to make you system work properly again

Show more replies
  • Liked by
Reply
Cancel
0 on 06-10-2016

I installed the 16.10.1 drivers and am still limited to 30Hz.

  • Liked by
Reply
Cancel
0 on 07-10-2016

Same here with CAC-1070: worked fine at 2160p60Hz on Crimson 16.8.3. All newer AMD GPU driver versions reduce output to 2160p30. I’ve sent a frustration message to AMD about 16.9.1, but 16.9.2 and 16.10.1 have neither addressed the issue, perhaps it’s done intentionally by AMD as they have released the RX 480 with native HDMI 2.0 and want to push me towards buying it…. smart marketing.

Hope to get a firmware update for the adapter from Club3D support in response to a written request via the site menu. Seen someone wrote that this may resolve the issue.

Buying an HDMI 2.0 GPU card will be the last thing I will do – in revenge for that they have delayed it for years keeping my UHD TV useless until Club 3D have finally resolved the matter. AMD have lost the momentum with HDMI 2.0 – too late.

  • Liked by
Reply
Cancel
5 on 07-10-2016

i’v the same problem i’m fix at 30hz for 4k after update lastest radeon software v16.10.1 and the same after remoove the last version

on 07-10-2016

please load a system restore point from before the problems started to make you system work properly again

on 07-10-2016

of course I’m back on 16.8.3 from restore, but AMD keeps reminding of an available update and this just isn’t right. We expect a fix from Club3D as AMD does not tend to be interested in doing this.

Thus actually, the CAC-1070 product doesn’t work as stated by the manufacturer (with the latest GPU drivers). It’s not working and a rollback is a workaround.

on 07-10-2016

Of course we informed R&D on this and they are working to find out if there is a way to fix the problem that hte new AMD causes. Will keep you all posted on devellopment.

on 07-10-2016

Thanks a lot! Much looking forward to it!

on 11-11-2016

i play only at assetto corsa…, i’v remoove my amd software in 16.8.3 and its ok on 60Hz 4K

Show more replies
  • Liked by
Reply
Cancel
0 on 07-10-2016

okay no problem – lets all just never update our drivers \o/

/sarcasm off

hoping that you guys find a solution soon, I appreciate that you even care and respond while AMD just sits back and doesn’t give a F

  • Liked by
Reply
Cancel
1 on 08-10-2016

https://community.amd.com/message/2753570#comment-2753570

There is a thread on AMD’s forum about this and it looks like there is a problem with 4K60Hz even if you aren’t using an adapter. The last reply is a guy with a RX480 and RX460 and he claims if you turn off the display and turn it back on again, you get 60Hz again. I won’t be around my PC all day or I would have tested it already.

on 10-10-2016

I tried it and there was no change form me.

Show more replies
  • Liked by
Reply
Cancel
1 on 11-10-2016

Another possible fix from the AMD forums. Turn on UHD HDMI Ultra Deep Colour in your TV settings seem to allow 60Hz on a couple of different TV’s. Will try tonight and report back.

on 11-10-2016

I can confirm that this works. I now have 4K60Hz again.

Show more replies
  • Liked by
Reply
Cancel
0 on 06-11-2016

Well well, gave it another try today – clean uninstall, installed new driver 16.9.2, 30 p in 4k possible.
Uninstalled, back to 16.7.3 and i get 60p in 4k.. waste of time trying.

  • Liked by
Reply
Cancel
0 on 06-11-2016

I have no such option for ultra deep colour on my TV… only viable drivers are still 16.7.3 and 16.8.3 getting seriously pissed off at the monumental amount of money wasted on not only this adaptor but also the R9 Fury graphics card. 

  • Liked by
Reply
Cancel
1 on 07-11-2016
Mkfish, I got even deeper into the mess with HDMI 2.0 by recently buying the Radeon RX 480 with HDMI 2.0 – it’s worse than when I had the R9 380 with CAC-1070 adapter as now I only have 3840×2160 60Hz with YCbCr 4:2:0 !!! and no option for a full pixel format on the latest Crimson 16.11.2 drivers, like it’s HDMI 1.4b… compatibility issues they say.

Everybody is pissed off with this sales strategy fraud. They sabotage us, they’ve decided upon it when UHD TV’s were released A DECADE AGO. They want more money and us to buy Computer Monitors with DP inputs instead of TV’s and there is probably an informal agreement between TV and Monitor departments to prevent TV’s with DP inputs being produced at all for preserving revenues. Resolving this simple issue would KILL the Computer Monitor market segment completely.

I wonder how Club3d have managed to survive getting their active adapter on sale anyway.
So relax, we are all suffering.

Another Conspiracy theory.

on 17-11-2016

Did you set color depth to 8bpc?, got alot of info on my blog
https://nwgat.ninja/club3d-displayport-1-2-to-hdmi-2-0-adapter-review/

Show more replies
  • Liked by
Reply
Cancel
1 on 22-11-2016

well i tried a lot of things, DDU in safe mode, installed newest driver. only 30p
tried ultra deep color – no picture at all.
tried custom resolution – error message – 30p.

Rolled back to 16.1.1 works perfectly in 60p – no perfect solution though.

i hope the vega cards will have hdmi 2.0..

on 23-11-2016

Hi Robzon.
16.8.3 should also work fine, at least a bit newer than 16.1.1 …

Show more replies
  • Liked by
Reply
Cancel
1 on 15-12-2016

Anyone tried if the new ReLive driver fixed the issues?

on 15-12-2016

I’m not even going to bother trying, there’s nothing about it in the release notes. And the list of new bugs in the release notes is like a laundry list.

If it somehow fixes it, I’ll eat my own head…

Show more replies
  • Liked by
Reply
Cancel