R9 280x royalQueen not detected on new mobo

Updated on 30-11-2015 in R9 280 Series
1 on 24-11-2015


I recently bought a new motherboard (Gigabyte Z97P-D3) + processor (Core i5 5675C), but my graphics card (R9 280X royalQueen) won’t work in this setup: the card does not get detected at all (not in bios, not in windows). I already contacted tech support of the motherboard, and they recreated my setup (with a r9 280x of their own brand), without issues. I already tried a lot of things:

– Inserted in PCIe 16x slot, removed, reinserted, checked power cables several times
– Tried older card (Club3D Radeon HD4790) in the same PCIe 16x slot without issues, so the slot seems to be OK
– Tried 280X card on old motherboard (GA-MA790XT-UD4P) with same PSU, and this works perfectly. So both the card and PSU seem to be OK (I used both for several months in the old rig before this upgrade)
– Since onboard graphics work, I tried disabling this in BIOS: this gave beeps during POST (no gfx found).
– Set BIOS startup display to PCIe1 and PCIe2, no change
– Updated BIOS, no change
– Changed all BIOS drivers settings I could find from EFI to Legacy, tried loads of combinations

Only remaining action I can think of is updating the GFX card BIOS.

Any ideas?


  • Liked by
0 on 30-11-2015

Hi Stijn,

We are already dealing with this thru the support mail, so i will close this one.

  • Liked by