MST CSV-5400 – cannot extend 4th display

Updated on 31-08-2017 in MST Hub
20 on 22-08-2017

Hi i tried to connect 4 hdmi passive adapters on the DP output to connect 4 hdmi TV’s with HDMI.
3 are working and the 4th is visible. But when i tried to extend it as i do with all the other 3 it cannot be activated in Windows .

The MST hub is connect to a Asus RX550 AMD. anyone has the same issue ?
The only option which worked was to only connect 3 on the hub and 1 on the hdmi out of the AMD RX550.

  • Liked by
Reply
0 on 22-08-2017

Hello mrk,

What screens are you using at what resolution ?
So i can check with technical department to see if we can test this.

  • Liked by
Reply
Cancel
0 on 22-08-2017

1920×1080 TV 4 pieces

  • Liked by
Reply
Cancel
1 on 23-08-2017

I am curious if anybody else managed to have 4 working hdmi monitors on this hub. Anyone ? And if so what is your setup?

on 24-08-2017

Hi mrk,

Just tested a CSV-5400 on a R7 370 with 4 x HDMI screen wihtout any issue.
Then replaced the R7 370 by a RX550 and everything was working strait away wihtout doing any settings. The AMD Driver however did not recognize the RX550 card. After removing existing driver and installing RX550 Driver we also encountered issues. Sometimes witht he third screen and sometimes with the 4th that was connected (both 4K screens natively). Screens were not recognized and therefore system did not allow advanced display setitngs to be done.
Did you already check with AMD on this ?

Show more replies
  • Liked by
Reply
Cancel
3 on 24-08-2017

I have setup a freshly new installed W10 with the latest updates. And the RX550 has the drivers from AMD . (see screenshots for detailed info)


is this ok? or did i use old drivers ?

on 25-08-2017

I don’t think there is anything wrong with your settings.
You use passive DP to HDMI adapters plus normal HDMI Cables ?

on 25-08-2017

Yes all identical

on 25-08-2017

We will try to get information from AMD on this … will be continued …

Show more replies
  • Liked by
Reply
Cancel
1 on 25-08-2017

is there a utility you can download to see what firmware is on the MST hub? maybe it’s an older version ?  and this is the screen you will see when trying to connect the fourth monitor on W10

on 28-08-2017

I will have [email protected] send you an email on that.

Show more replies
  • Liked by
Reply
Cancel
1 on 28-08-2017

i used the tool and first checked the firmware. it reads V0.60 so i think it’s up to date.
Can you check this (see screenshot)

on 29-08-2017

Yes that MST Hub has the latest 0.60 firmware indeed.

Show more replies
  • Liked by
Reply
Cancel
1 on 29-08-2017

I hope you have a sollution why it is not working…

on 30-08-2017

Hi mrk,
Not at this point. Since the MST Hub is working wohtout the driver of the RX550, meaning the MST HUb is ok, R&D needs to find out what AMD changed in the driver to cause this, before they are able to fix this by firmware update (if possible). Unfotunately this is a time consuming process and it could be that AMD will come with update for the driver before that time …
We will keep psuhing in search for a solution int he meantime and will get back to this whenever we have an update …

Show more replies
  • Liked by
Reply
Cancel
1 on 30-08-2017

As read in your previous posts you had it worked with an RX 550..or not ? and if so did you use a older driver ?

on 30-08-2017

Yes it did work with a driver for the R7 360X, not sure anymore which version that was,
adn it also worked without AMD driver. Last driver made for R7 / R9 / HD series was the 16.8.3, in case you want to try that out … 
http://support.amd.com/en-us/download/desktop/previous/detail?os=Windows%2010%20-%2064&rev=16.8.3

Show more replies
  • Liked by
Reply
Cancel
1 on 30-08-2017

if i search for drivers for the R7 or R9 series you always end up with the latest drivers 17.7.2 or the optional 17.8.2. these are the latest working drivers. hmmm..strange.

I will wait if there is a sollution. or i have to buy a second hand R7 card and test it out with W10 and have the same results as you do.

on 31-08-2017

Hi mrk,
here you can find a listing of AMD graphics drivers.
http://support.amd.com/en-us/download/desktop/previous?os=Windows%2010%20-%2064

Show more replies
  • Liked by
Reply
Cancel
1 on 31-08-2017

it’s not that i couldn’t find the old drivers but that u say u use the latest drivers v 16.8.3..you also can install 17.7.2 or 17.8.2.

on 31-08-2017

the latest drivers made for R7 R9 series was 16.8.3. After that AMD made many driver updates but all aimed at RX series. Because I am not sure which of those is causing the issues, i advised to try the 16.8.3 driver becuase i know the MST Hub will work with that driver loaded.

Show more replies
  • Liked by
Reply
Cancel