CAC-1531 USB Gen1 Type-C extension cable won’t connect mouse and keyboard

Updated on 15-03-2024 in USB Type C
11 on 12-03-2024

Hi, I recently bought an extension cable, the CAC-1531, to extend the connecting usb-C plug of a small usb-C hub which has an HDMI-display, keyboard, mouse and power supply (60W) connected to itself. The display signal works fine, so does supplying my laptop with sufficient power, but the keyboard and mouse (both usb 2.0 devices) does not work through this cable.

Am I just unlucky to have received a faulty cable? I expect newer usb devices and cables to be backwards compatible with previous generations.

 

To fault detect, I have tried:

– using the cable to connect/extend a Lenovo display with usb-c hub; display works but no (usb 2) mouse, keyboard, headset, space mouse works.

– using the cable to connect/extend a Lenovo thunderbolt 4 dock with usb-c plug; display works but no (usb 2) mouse, keyboard, headset, space mouse works.

– Using it to connect a usb-stick (usb 2.0 A male) with a usb-3 A to usb-C adapter to an Android phone as OTG storage = no connection. (usb-stick and adaoter works fine without the CAC-1531 extension cable).

– Connecting a USB 3.0 external hard drive to my PC, which work fine.

Please advice what I should expect from a “USB Gen1 Type-C _Extension_ cable. Is mouse and keyboard not considered “Data”?

(hopeful)

 
  • Liked by
Reply
1 on 14-03-2024

Could you give the exact make and models of, Laptop, USB-C hub, keyboard, headset, Pretty much your entire setup?

For example, a Lenovo display with Usb-c hub – This could be a hub on the display, or a seperate hub, I can’t tell at the moment.

on 14-03-2024

Laptops tested: Lenovo Thinkpad P14S Gen 3, P16 Gen 2 (separate power supply).

Android tested: Samsung Galaxy S10e,

Lenovo Display with hub P27h20: power and display works (for Android and P14S)

Thinkpad Thunderbolt (4?) dock: only display works (attached via DP) (for P16)

Lenovo USB-C 7-in-1 hub LC700: Power and display works (attached via HDMI) (for P14S)

In any case, none of the attached USB 2.0-devices work:

keyboards: Logitech Deluxe 250, Logitech media keyboard 600

Mouse: Logitech M705 (several)

Headset: Plantronics C720M

Space Mouse; 3D connexion Space Mouse Compact

Show more replies
  • Liked by
Reply
Cancel
7 on 14-03-2024

I’m having a similar issue with steam deck and it’s dock and a similar CAC-1529 product. The extension cable transfers power and Ethernet signal, HDMI and DP signals, but USB devices don’t connect to the steam deck. Using no extension or using a cable from a another brand works fully.

on 14-03-2024

Intresting, I just ran some tests using both CAC-1529 & CAC-1531. And indeed my USB connected devices did not work. So I removed the extension cable, plug the dock directly in to the laptop I used. And the USB devices worked, then I hot-plugged the Extension cable and gave it a few seconds, and every USB devices connected came to life.
My Setup included power delivery to the laptop and a 4K60Hz display.
Can you check this?

on 14-03-2024

I’m not sure I know what hot-plugged means, but I connected my dock directly to the deck and had the USB devices working correctly, then I put the extension cable between the dock and the deck while the deck was on and the USB devices did not work even after waiting for over a minute.

My set up has the dock connected to power supply, the dock connected to steam deck. and a wireless keyboard transmitter, Xbox controller and wireless headphone dongle connected to the dock. I can connect an external monitor 1080p monitor and Ethernet without any issues using the extension, but USB devices don’t light up. They do receiver power through the dock but they don’t “wake up” as they do when you turn on a computer.

on 14-03-2024

Hot plug means that everything is on and add the cable to it.

  1. remove extension cable
  2. plug every USB device in the steam-dock
  3. Connect Steam-deck without extension cord to steam-dock
  4. turn Steam-deck on let it find the USB devices
  5. When all USB devices are found, do not turn off the deck and add the extension cable
  6. If above does not work or you have done this go to 7
  7. Turn off Steam-deck add extension cable
  8. Turn on Steam-deck

Solved?

I tried with a wireless mouse, and it worked for me with my setup. Could be a weird glitch caused by the Steam OS ran on Linux.

on 14-03-2024

I have done steps 1 through 5 for a couple of days now and 7 to 8 too. I originally thought my dock was faulty so I went through all kinds of solutions that people had suggested for it.

I don’t have many USB C devices but I do have a phone, and that connects fine to my PC computer with any other USB C cable, so I can transfer files etc, but this extension cord again just charges the phone and it doesn’t appear on the PC.

So, for you the USB devices were not connecting when using the extension cable but then hot plugging after they had been recognized fixed it? For all tested devices?

on 15-03-2024

Yes, I used a Dell XPS, a dockingstation CSV-1564, and the CAC-1529 & CAC-1531.
At first the USB devices did not work, but after the steps provided, both  wired mouse and keyboard worked. Then did the same steps with a wireless mouse and it also worked.

Quite an odd issue.

Have tried wired peripherals? Or adding wireless devices one at the time?

on 15-03-2024

These are the things I’ve tried, things that work every time when not using the extension cable. They work when plugged in when powering up, when hot plugged while the device is on, after removing the extension cable from between Dock and Deck while the Deck is on.

Wireless:

K400 Plus Wireless Touch Keyboard
HyperX Cloud Flight Heahpones
Logitech G Pro X Superlight Wireless Mouse

Wired:

Razer Wolverine TE Xbox One Controller
Samsung Galaxy A52s 5G Smartphone
Samsung M3 Portable HDD
Logitech G502 HERO Mouse

I have tested them with Steam Decks Game and Desktop modes and they work in both without the extension. I have connected them all successfully to my Windows 10 PC desktop without using the cable, and they don’t get recognized when the extension is added.

Can you confirm if your USB devices are still not working initially unless you hot plug them, or was it a long term fix for you? Thank you for help in trouble shooting, I will attach this thread to my support to support.

on 15-03-2024

Long Term, they still work. Even after rebooting.

Show more replies
  • Liked by
Reply
Cancel
0 on 15-03-2024

Edit: double post

  • Liked by
Reply
Cancel