The CAC-1070, AMD R390, SAMSUNG JU6650, Windows 10 64x Challenge

Updated on 09-05-2016 in Adapters and Cables
18 on 08-04-2016


It’s quite a long post as I had some trouble signing up on the forum somehow.
I have kept a log of my troubles connecting my 4k screen at 60Hz with the CAC-1070 but I am making subtle progress.

The situation is as follows:

My setup:

  • Win10 x64
  • AMD R390 (Gigabyte GV-R939G1 GAMING-8GD)
  • CAC-1070
  • HDMI 2.0 certified cables (bought a shorter one of 1meter to rule out cable lenght)
    • sharkoon HDMI 2.0 “supports 4K x 2K 60Hz” 1.0m
    • Sandberg HDMI 2.0 “4k@50/60 2160p” 5.0m
  • TV Samsung UE48JU6650S
  • External Display HPw2207h (Via HDMI 1650*1050)


Output is maximum of 4k @ 30Hz.
I have tried to resolve the issue as follows:

  • Disconnect cable from TV
  • Installed latest firmware updates TV (v1443)
  • Apply UHD Color setting to ‘ON’ on HDMI 1 port (STB/DVI)
    1. Note: Tv reports: “This mode is optimized for UHD 50p/60p 4:4:4 and 4:2:2 signals”
  • TV resets
  • On TV label input source HDMI 1 as: ‘DVI PC’
  • Connect HDMI 2.0 cable to HDMI 1 port (STB/DVI)
  • Installed latest Crimson Drivers 16.1.1
  • Configure 8 bit video output through ‘Radeon Additional Settings’
    1. Note:
    2. Reported Display Name: SAMSUNG
    3. (In Windows>Advanced display settings > display adapter properties > Monitor, the monitor type is reported as: Generic PnP Monitor)
    4. Max reported resolution: 4096×2160
    5. Max reported refreshrate: 75 Hz
    6. Multi-streamtransport capable: No
    7. Current color depth 8 bpc
  • Restart PC
  • Via Windows advanced display setting, select 4096×2160 (recommended) resolution
  • Tried via display adapter properties / tab ‘monitor’ to select 60Hz. Not there.
  • Repeated proces above with second cable, not working.
  • Adjusted screenresolution to 1080p 24Hz as suggested, restarted; 4k @ 60Hz still not listed
  • Updated firmware of CAC 1070 to 0x07 0x23
  • Updated AMD drivers to 16.3.1.
  • Retried adjusting screenresolution to 1080p 24Hz as suggested, restarted; 4k @ 60Hz still not listed
  • Set custom resolution at 3840 X 2160 progressive CVT-reduced blanking
  • This partially resulted in success. I noticed the refreshrate was 60Hz but there was a Haze or pixelarity throughout the screen which resulted in unreadable texts (see picture).

This is the result of custom resolution with reduced blanking. The image size on screen suggests 4k resolution, however the TV reports 1080P @60Hz.
The pixels are sharp so the image is in focus. However, the text is unreadable.

  • Retried custom resolution under following circumstances:
Label Source input Gamemode UHD Color Outcome
PC On On haze
PC Of On haze
PC On Off haze
PC Of Off clear, but TV indicates 30p, youtube 24p, MSIafterburner 30p


retest: Haze

DVI PC On On haze
DVI PC Off On haze
DVI PC On Off haze
DVI PC off off Haze,
  • Noticed that after each try at custom resolution, the timing standard was put back to CVT, rather than CVT-reduced blanking.
  • TV reported the hazed 4k image as 1920x1080p @60 Hz
  • Reselected custom resolution 3840×2160 @ 60 Hz in mode DVI PC, Game Mode ON, UHD Color ON, I accepted the hazed image (no revertion) and rebooted in order to see if TV recognized and accepted new forced 4k signal. Failed, after reboot TV saw signal as HD. Hazed image remains
  • Started Advanced display settings in windows, to check status. It reported 3840×2160, @75Hz. Downgraded this to 60Hz, screen then it automatically resized to 640×480 @60Hz (according to TV). Reselecting custom resolution through windows 3840*2160 resulted in non-hazed 30Hz non-fullscreen image.
  • Next fase to reinstall windows10 as suggested, however, skeptical of relevance. Has this reportedly been effective for others?

Two weeks later:

  • Before reïnstalling windows I went with my CAC 1070 to the store (Thanks, MediaMarkt), connected my cable to a gaminglaptop displayport 1.2 and identical Samsung ju6650 TV on settings: UHD ON, Labelsource PC (just as )
  • This worked instantaneously. This rules out the fault is within
    1. the cable
    2. the CAC-1070 adapter
  • So it must be either
    • AMD R390 Gigabyte GV-R939G1 GAMING-8GD
    • Driver,
    • Windows 10 64x
    • Samsung HDMI-port.
  • At home I reïnstalled windows 10 64 bit: by resetting this PC, delete all files (get rid of old windows 7 files)
  • Installed Crimson 16.4.1, reset television (to English language like in the store), UHD ON, input source labelled as PC,
  • Power off PC and Television, connect cables. Power up.
  • Got Error message from Radeon that “there is a problem with my Displayport preventing me from using the highest resolution”. Effective resolution 3840*2160 @30Hz
  • Configured 8 bit, tried all three displayports, custom resolutions hazed. No success yet.

Next step is to bring home another device with displayport 1.2, to make sure the television accepts a 4k60Hz signal. That would narrow down the root cause to the computer’s end.

I wonder if you have any more suggestions or things I overlooked.

I’ll keep you posted,

  • Liked by
2 on 17-04-2016

Last week my brother in law came over with his PC (windows 7 x64, 15.11 drivers) which contains a Sapphire R290.

His system, his GPU
When we started his Windows 7 system, the CAC-1070 worked instanteneously at 4k60p:

This picture is his system with 15.11 drivers in Windows 7

To my understanding this rules out the possibility that my Samsung screen is the culprit.

Next, we decided to swap the videocards:

  • My R390 into his Windows 7 system (15.11 drivers)
  • His R290 into my Windows 10 system (16.4.1 drivers)

Left his system with my AMD R390 Gigabyte GV-R939G1 GAMING-8GD
Right my system with his Sapphire R290

My system, his GPU
We started up my system with the R290 which resulted in success:

This picture is my system with a R290 with 16.4.1 drivers in Windows 10.
To my understanding this rules out the possibility that Windows 10 is the issue in my case.

His system, my GPU
Next we were very curious of course wether or not my R390 would work in his system.
Alas, when we fired up the R390 in my brother in law’s system, the video-output was capped at 4K@30Hz.

To me it seems it must be my AMD R390 Gigabyte GV-R939G1 GAMING-8GD.
However I am still not quite sure it is hardware or software related. 
Could it be that the 8GB of VRAM plays a part in this?

I am looking forward to your advice.




on 17-04-2016

Edit: 15.11 should be 15.12

on 19-04-2016

Hey man, thanks for the informative and in depth post. I am having the exact same problem as you. The difference being that I have an LG 4k tv instead of your samsung. I also tried many different HDMI cables and drivers, today I even decided to wing it and reinstalled windows 10 and still the problem persists so I went and got a replacement adapter from amazon and it still didn’t work. I tried displaying my gaming laptop to my 4k tv to make sure it can run at 4k60fps using the adaptor and it works perfectly. So I think the only conclusion is that our GPUs are the problem in this mess. I hope clud 3d works this out because I would love to use my pc at 4k.

Show more replies
  • Liked by
0 on 20-04-2016

I’m glad to hear the good news,you’ve found the issue,thanks for feedback.

  • Liked by
2 on 20-04-2016

Hi All, 
R9 390 in general does not have a problem with support for CAC-1070. Perhaps your particular card. Since it is working correctly for the rest, please check with Gigabyte for a Bios update.
Also be sure to remove all Intel Graphics software (if that is on your system).
Please also check for Bios Update for your mainboard, and check in Bios for CSM (Compatibility Support Module). If your Mainboard has such a setting, please Disable that.
Also Disable GPU Scaling in the Graphcis driver in case that is enabled.

on 20-04-2016

Isnt there anything you guys can do? like update the adapter or something? I checked for bios update for everything you mentioned and I seem to be up to date on them. SO my only hope is for club 3d to come through since it’s almost impossible to get in touch with gigabyte, much less explain the situation… 🙁

on 20-04-2016

Great to hear that it is not just me.
Also I am glad it is not the CAC-1070 adapter or Samsung screen.
Any help from Club3d from this point forward is highly appreciated though.

First of all, Labatomi, do you confirm you have the exact same GPU as I do? I have the AMD R390 Gigabyte GV-R939G1 GAMING-8GD.
Also, can you provide your driverversion and motherboard?
My motherboard version is H170M-A Pro (MS-7972)

As for the Tips of MST1407, I have done the following:

1. Upgrade firmware GPU to newest version (F91):


2. GPU scaling is off

3. Updating Bios
Download from: 
<a href="”> version B3

Old Bios:


New bios:

Thusfar no solution yet.
Two things still yo try:
1. CSM (I cannot find this within my updated bios, can you advice where it should be located?

2.Remove Intel graphics software
Can you advise on which steps to take here?



Show more replies
  • Liked by
0 on 21-04-2016
Thats my hardware info there. I also didn’t see the CSM thing and I don’t have the intel drivers since I don’t use my CPU’s GPU.

  • Liked by
2 on 21-04-2016


So I finally got my email from club3D about the firmware update, I followed their instructions to the letter and updated. And after restarting my computer it automatically started up in 4k60fps. So it seems to be working perfectly!!!! I restarted my pc a few times and it’s still working great! everything looks so damn crisp! and it no longer gives me that displayport error when I restart my pc. the BPC is also grayed out!

on 21-04-2016


on 21-04-2016

Thanks I just hope it doesn’t mess up again after a few days.

Show more replies
  • Liked by
1 on 21-04-2016

Can you indicate your version of the firmware? is it 0x07 0x23?

on 22-04-2016

Hi friend,the lately released fw version is 0x07 0x23,

Show more replies
  • Liked by
0 on 22-04-2016

And it’s back to 30fps. I also purchased the uptab adapter and it works the same way. So I’m just going to return them and purchase a new GPU when they release in a few months. I’m honestly done trying to deal with this thing.

  • Liked by
3 on 02-05-2016

Today I emailed Gigabyte on the matter:

Dear Gigabyte: 

I have purchased the Club3d CAC-1070 Displayport1.2 to HDMI 2.0 active adapter. This device should enable the Gigabyte R390 to output 4k@60Hz to my Samsung 4k television over HDMI. However, the framerate is capped at 30 Hz.

I have tested extensively with different:
– drivers
– cables
– OS
– GPU Firmware
– Motherboard Firmware
– Other GPUs (R290) and Laptop
– Other configurations entirely

Be advised, I have seen my TV, Cable and CAC-1070 adapter work in combination with an other GPU. Therefore I will have to conclude the problem is isolated to my Gigabyte GPU.

Please attend to this thread I started on the club3d forums for further information and photographs:

My username on that forum is ErikG.

I hope to hear soon on any advice or solution you offer to my case.



on 02-05-2016

Thank you Erik, we’re very interested to know if they can share any info on this!

on 06-05-2016

I have just received an e-mail that Gigabyte is checking with the responsible team.

on 09-05-2016

Today I got an answer by Gigabyte, not quite the answer I had hoped for: 

Dear  Erik ,
AMD Radeon R9 390 only can reach 4K@30Hz due to HDMI version 1.4a.
Only HDMI 2.0 can reach 4K@60HZ via HDMI port. On the other hand, the display devices should be support HDMI 2.0 as well.

I emailed them back:
Perhaps I was unclear in my formulation, but I am quite sure you missed my point unfortunately. I will retry:

I was and am aware of the technicical limitations of HDMI 1.4a which is located on my R390 card (this is 4k 30Hz). So far so good.
I am also aware HDMI 2.0 is needed for 4k 60Hz.

This is exactly the reason I bought a CLUB3D CAC-1070 adapter (please familiarise yourself with this adapter before continuing:

It converts the Displayport 1.2 output to a HDMI 2.0 output.

My device chain setup is as follows:
Computer>Gigabyte AMD R390 > displayport 1.2 > CAC-1070 > HDMI 2.0 > HDMI 2.0 cable > HDMI 2.0 input on UHD TV Samsung JU6650.

Superfluously, I have not connected to the HDMI1.4a port, but to the Displayport.

Within this device chain I have exchanged all devices in order to isolate the problem:

  • I downgraded to 8bit color depth
  • I have tried a different HDMI 2.0 cables
  • Then I tried different drivers (catalyst to crimson 16.5.1)
  • I tested with all configurations on my Monitor (UHD Color ON, source input etc)
  • I reïnstalled windows
  • I updated the firmware of Motherboard
  • I updated the firmware of GPU
  •  I brought the CAC-1070 adapter and my cables to a store where I tested with an identical SamsungJU6650 Monitor and a gaming laptop with displayport 1.2 (this was succesful and rules out the problem is in the cable or CAC-1070 adapter)
  • I brought over a friend’s computer with a R290. I connected his PC to my TV via Displayport 1.2 > CAC 1070 > HDMI 2.0 > Cable > Samsung and it worked at 4k60Hz. Note: this confirms that my display device support HDMI 2.0 as you mentioned.
  • Next, I placed his R290 in my computer/motherboard. I attached the CAC-1070 to the displayport 1.2 of the R290 and the adapter’s HDMI 2.0 output provided 4k60Hz. This rules out that the rest of my setup or OS is the problem.
  • Next I placed my Gigabyte’s R390 in his system and connected the screen in the same way (DP1.2>CAC-1070>HDMI2.0>Cable>Samsung. This did not work.

This leads me to the conclusion it cannot be another device than the Gigabyte R390.

  • I have seen my television work,
  • I have seen my cable work,
  • I have seen the CAC-1070 adapter work
  • … R390
  • I have seen my system work (be it with an other GPU). 
  • The only time it does not work is in combination with the Gigabyte R390.

Please advice on how to proceed or what support I can count on from Gigabyte. Can you recreate/recognise the problem? If so can you provide firmware update if it is software related or exchange my GPU for an identical one to rule out hardware related issues?

I hope I have more clearly described the issue at hand.
I am looking forward to a workable answer.


Erik Guldenaar

ps. please attend to the thread on the CLUB3d forum where I have posted pictures of the tests I described here.

Show more replies
  • Liked by