R9 280 low frame rate and games will not display.

Updated on 19-05-2015 in R9 280 Series
2 on 19-05-2015

I have a Club 3D R9 280 which recently has started having low frame rates <30fps> and now will not display Titanfall. I run the game and it runs in the background but each time it tries to display to my screen it drops back to the taskbar. Normally, the game would just error out and I would open again and it would run fine (but for the low FPS). But now it does the same running in the background. So I swapped it with my 7950 which was what I had planned to Crossfire it with and the 7950 runs perfectly with 60 FPS, and no errors. Also, when using the 280, every time I exited Titanfall I got an error message that the game had stopped working, despite exiting correctly, this does not occur with the 7950. Do I have a bad card? Also, when it did work I always got clicking in my monitors when I started any of my games (Battlefield, call of duty, titanfall, etc.), never does this occur with 7950. I’m running 3 monitors (Displayport, HDMI, DVI). Do I have a bad card? It’s only 5 months old.

  • Liked by
Reply
0 on 19-05-2015

Hi Megaman73,

Your question was answered thru our support email.

Thanks

  • Liked by
Reply
Cancel
0 on 19-05-2015

Hi Megaman,
Sorry to hear about the problem.
Are you running at 5760×1080 or Eyefinity 3? Do you have V-Sync enabled?
We know that this game has some issues with V-Sync and it does create issues having low framerate.
Can you look up this utility  Radeon Pro?
Check by limiting the framerate if it helps.
Do you have any issues with other games as well?

  • Liked by
Reply
Cancel