CAC-1070 and 1170 HDMI 2.0 adapter feedback topic.

Updated on 08-05-2018 in Adapters and Cables
2 on 09-12-2017

Hi all, very interesting reading here! Great to see so many people going for [email protected]

I am wondering if the CAC-1170 will work for me? My setup:

  • MacBook Pro (Retina, 13-inch, Early 2013, A1425)
  • 3.0GHz Intel Core i7-3540M Processor
  • Intel HD Graphics 4000
  • Dell P2415Q UHD display
  • SwitchResX

I cannot find max resolution for this CPU/GPU combo. The Intel page does not show it?

I’m currently using a ICZI mDP to DP certified cable and am stuck at [email protected] which makes me sad 😉

on 11-12-2017

Hi Matt,

Normally you would need at least HD 4600 Graphics (Haswell Generation) before the Intel graphics  will support 4K 60Hz output over DP 1.2. So i would say they issue is the Graphics.

on 11-12-2017

OK, thanks. I guess I will go back to Thunderbolt Display 2560×[email protected]

Show more replies
  • Liked by
4 on 03-01-2018

Mini DisplayPort 1.2 to HDMI 2.0 Active Adapter only delivers [email protected], how do I make it work at 30hz? I am using 2013 mac pro and samsung U28E590

on 03-01-2018

Hello Phil,

Did you check if your MacBook Pro can actually output 4K at 60Hz ?

on 03-01-2018

I have a late 2013 Mac Pro. (the thing that looks and occasionally acts like black trash can)… yes it does. I have verified this by hooking up via DP1.2 to DP1.2 cable on another monitor and got [email protected]

on 04-01-2018

Hello Phil,
Ok good to hear it is working 🙂

on 14-01-2018

He’s not saying the adapter is working, he’s saying he knows that the adapter is the problem because the computer supports 4k60 in a different configuration.

Show more replies
  • Liked by
0 on 13-01-2018

Dual booting windows 10/hackintosh high sierra. Needed adapter for hdcp 2.2 on window side and still get [email protected] on both. The problem is when PC goes to sleep monitor will not awake on both windows and hack. I have GTX 1050ti with lastest drivers, LG27UD69p monitor and lastest firmware from club3d. Have tried different bios options Input PEG,IGPU, PCI with same outcome. Now out of options or am i missing something?

  • Liked by
2 on 15-01-2018

Hi, having a problem with the club 3D mini dp 1.2–>hdmi 2.0 adapters.
The issue is something i read alot of people have, its getting real 4k in 60hz as a choice instead of making a custom resolution.
I only get 30hz. Any advise on how ton fix this?
I’ve also tried the cable directly to the tv instead of through the receiver just in case, but still get the same issue…
There is a requirement from gpu’s, adapters and hdmi cables. I’ve met them all.

My Hardware:
Computer: intel nuc5i5RYH with intel hd 6000 and 16gb ram
Tv: Lg Oled65C7
Receiver: Denon X5200W
Adapter: Club 3D Mini DisplayPort 1.2 – HDMI 2.0 UHD Active Adapter CAC-1170
HDMI cable: Hdmi 2.0 premium 21gbps bandwith

I’ve seen that some from the club 3D teams advise in making a custom resolution and changing the speed timing in the gpu settings from the standard and default setting GTF to CVT-RB and that that will fix the issue. Wouldnt that be like fake 4k 60hz? Since this method requires less bandwith to get 4k 60hz, I see the reason of this workaround in 2016, but is there a solution now in 2018?

on 15-01-2018

Im also using the newest drivers for my intel hd 6000 graphics card and the newest BIOS firmwire from Intel.

on 16-01-2018

Hello Smaskz,
Why would making a custom resolution with timing standard at CVT-RB not be a “real 4K 60Hz signal” ? 
CVT-RB is a setting that is better suited for newer (faster) screens, reduces blanking pauzes that use to be necessary with CRT Screens,

Show more replies
  • Liked by
0 on 11-02-2018


I have a problem with my adapter.
He writes on the sticker
REV B0-00
FW V7.55

I use LibreELEC (linux) in my HTPC. I have a motherboard gigabyte z170x gaming 7 + intel kabylake.

After connecting the adapter, the system shows me the resolution of 3840x2160x60hz. And it works well. The problem is with the sound. The adapter is connected to the receiver and either the stereo sound works and it stops working multichannel until the computer is turned off, or it works multichannel and there is no stereo sound until the computer turns off. The adapter loses synchronization and on my receiver I see that the “HDMI” icon disappears.
Someone on the LibreELEC forum wrote to me that he works with LibreELEC very well and he had no problem with it. He wrote to me that he had other problems at the beginning and he did Firmware updates and helped him. He advised me to ask for firmware updates.

  • Liked by
2 on 12-02-2018

I can see that my request which I sent to [email protected] takes 2 days.

on 12-02-2018

Good day kowalmisiek,
Sorry fo the delay but my colleagues at support will always try to reply asap, This normally means you will get a reply the same day or within 24 hours, however they do not work on the weekend.

on 12-02-2018

Teh UHD sound driver is integrated in the Graphics Driver. which Graphics Driver do you have installed ?

Show more replies
  • Liked by
1 on 12-02-2018

I made downgrade firmware to 0x46. Now the sound for me is stereo and multi-channel. Only sometimes there is a problem when I finish watching a movie (multichannel sound) the LibreELEC interface (code menu) stops working for me (sound). Then when I turn on the plug, for example, youtube (stereo sound), the sound returns and on my AVR HDMI synchronization appears.

I’m sorry but I do not even know how to check which graphics driver I have. I can say that I have LibreELEC 8.2.3 motherboard gigabyte z170x gaming 7 and intel kaby lake i5. Picture and integrated sound (intel kabylake).

on 13-02-2018

I was asking becuase it sounds like the adapter is working ok and your system is working fine, so the chance it is a software issue is quite large. Biggest influence in htis case would be the Intel Graphics Driver Pack whcih also contains UHD sound driver. Please check if you can find latest version for your OS for that one.

Show more replies
  • Liked by
5 on 27-02-2018

For me the CAC-1070 (x2b firmware) works only partially.
My setup:
Asrock Deskmin (H110-STX mobo)i
Intel G4600 (HD 630 kaby lake)
Windows 10 x64 (1709)
LG 55UX340C (UHD)
saphire HDMI cable rated for 4k 4:4:4 HDR

When I first got everything going about a year ago, everything worked. I was using the VGA driver from Asrock website ( and had 3840×2160 @60hz w/ all driver settings available and working. Specifically, I could use full quantization and YCbCr.
Then, starting with Intel driver 15.46 and later, the quantization setting was gone and selecting YCbCr would break the video signal. Without the CAC-1070 over DP, and instead using HDMI 1.4, the driver worked perfectly only at 30hz.
I have a thread going with Intel on this issue at:
I would continue to use the old driver that worked except it does’t have Netflix 4k support.
I’m just wondering if anyone else experienced anything similar and if there’s a work-around.

on 27-02-2018

Hell Jun1us,
For Kaby Lake it is better to update the firmware fro the adapter to “0.55” version.
Iw ill have [email protected] send you an email on that.

on 27-02-2018

Tried 0x55 firmware (unplugged adapter after update). This did not resolve the issue.

on 28-02-2018

Hi jun1us,
Did you try making a custom resolution in the Intel Graphics Driver ?

In general

  • Setup

Setups with TV’s normally work best by making a custom resolution, in this case for: 3840*2160 at 60 Hz with Timing Standard set to CVT-RB (Reduced Blanking).

(For setups with Monitors Timing Standard can remain on “auto”.)

On most TV’s you will need to do some settings like “Enhanced Mode”/ “PC-Mode” and/or “UHD Color” for the HDMI 2.0 port in use. 

Please make sure the HDMI port of the Screen/TV supports 4K 60 Hz, often not all HDMI inputs support that.


on 01-03-2018

Thanks for the suggestion. Tried it but no dice.
Keep in mind that I had 3840×2160 @60p working properly on an earlier Intel driver at standard resolutions, so I wouldn’t expect that setting a custom resolution with the later drivers that broke YCbCr and quantization would make any difference.
A few details I may not have mentioned earlier:
– Over HDMI 1.4 everything works as it should, just limited to 30p.
– Over DP with CAC-1070, even 3840×2160 @ 30p does not show quantization settings and breaks signal when put into YCbCr.
– With firmware 0x2b I had 3840×2160 @ 60p working properly with older Intel graphics driver
– Using another one of my systems with a GTX 1060 and the same TV and cables, I get 4:4:4 at 8 bit 3840×2160 @ 60p working without any issues
Please let me know if you have any other suggestions I could use to troubleshoot this issue.

on 01-03-2018

Hello jun1us,
Ok, the adapter is fine, so it must be software.
Problem is that software is in all the hardware. Please update all also TV.
Then my guess would be that the problem comes from the Intel Graphics Driver.
Great CPU’s but not the most “advanced driver software in the world”.
Is there any particular reason why you needed to update driver that was working ok ?

Show more replies
  • Liked by